Subject: Re: Notification: incoming/581

From: Dominik Vogt <[email-masked]>
Date: Fri, 17 Mar 2000 10:03:39 +0100

On Thu, Mar 09, 2000 at 02:39:02PM +0100, Non-HP-fvwm-bug wrote:
> FVWM Bug Tracking notification
> 
> new message incoming/581
> 
> Message summary for PR#581
> 	From: [email-masked]
> 	Subject: Configure Problem
> 	Date: Thu, 9 Mar 2000 14:39:01 -0600 (CST)
> 	0 replies 	0 followups
> 
> ====> ORIGINAL MESSAGE FOLLOWS <====
> 
> >From [email-masked]  Thu Mar  9 14:39:01 2000
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id OAA23142
> 	for <[email-masked]>; Thu, 9 Mar 2000 14:39:01 -0600
> (CST)
> Date: Thu, 9 Mar 2000 14:39:01 -0600 (CST)
> From: [email-masked]
> Message-Id: <[email-masked]>
> To: [email-masked]
> Subject: Configure Problem
> 
> Full_Name: Mark Manning
> Version: 2.2.4
> CVS_Date: 
> OS: SGI IRIX v6.5
> X_Server: SGI X Server
> Submission from: (NULL) (139.169.226.24)
> 
> 
> I downloaded the latest version today (3/9/2000) and ran configure (I
> also tried doing the "sh ./configure" - same results).  I'm running csh btw.
> 
> Configure worked ok until it got to the "System compiler" part where it
> stated I was using gcc.  We actually use cc.  Configure continued onto
> the next statement where it died trying to use gcc.
> 
> The problem, as I determined later, was that CC was not in the environment list
> and so configure probably tried to use some other means of determining what
> C compiler I was using.  If possible, configure should be reconfigured so that
> it tests for two or three of the most popular C compilers and then goes with
> the one which has the latest usage datetime stamp.  Or it could just ask the
> user what to do.  Whichever.
> 
> Just thought that someone would like to know about this.  :-)

You should report this to the automake/autoconf developers.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Fri, 17 Mar 2000 09:28:16 -0800

Previously from Dominik Vogt
>You should report this to the automake/autoconf developers.

Is this even a bug? The behavior I seem to be seeing is that autoconf
first looks for gcc, then cc. I work on a lot of commercial UNIX
machines without the C development kit, where we just install gcc
instead. cc tends to be present, but is just a stub that can't do
anything useful.

Personally, I think it's reasonable to assume that if gcc can be
found, that it's usable and worth using.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
"I am not a number; I am a free man!" - Number Six
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]