Subject: CVS migo: * configure: removed duplicated checks; fixed stroke auto-detection

From: CVS <[email-masked]>
Date: Fri, 24 Mar 2000 18:46:47 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	00/03/24 18:46:46

Modified files:
	.              : ChangeLog configure.in 
	fvwm           : bindings.c 

Log message:
* configure: removed duplicated checks; fixed stroke auto-detection
* Olivier's bindings patch fixing leaks and a crash (sorry, I can't wait)

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 29 Mar 2000 11:06:23 +0200

> * configure: removed duplicated checks; fixed stroke auto-detection

Mikhael, can you explain what you had to do to fix it?  I looked
into the problem myself, but I didn't understand the way autoconf
works.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 29 Mar 2000 12:45:54 +0200

> into the problem myself, but I didn't understand the way autoconf

I have added $X_CFLAGS in line 148 of configure.in (this is in ChangeLog),
so stroke.h, which is usually in X11 include directory, is found;
and added one more search directory to support one rpm.

When/if libstroke is getting more standard, it probably makes sence to
replace the current #include "stroke.h" with #include <X11/stroke.h>.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 29 Mar 2000 13:35:24 +0200

> replace the current #include "stroke.h" with #include <X11/stroke.h>.

Oops, then we're talking about different checks.  I thought you had
fixed the duplicate 'readline' options that appear when you
'configure --help' (Dan reported this).

Bye

Dominik ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 29 Mar 2000 23:09:43 +0200

> 'configure --help' (Dan reported this).

I tried to fix this several times :) without much success.
I mean I know why this happens - because of two smr_CHECK_LIB calls
every one adds its own usage lines (if the first is failed). But I didn't
succeed yet to fix this without touching autoconf macros. Will try later.

Regards,
Mikhael.