Subject: It's a patch to TaskBar ...

From: Oleg Cherkasov <[email-masked]>
Date: Fri, 17 Mar 2000 15:13:22 +0300 (MSK)

Dear Workers,

Here is a patch to FvwmTaskBar.  The fvwm version is a cvs one.  I have used
'cvs update; cvs diff >patch_file' command to get it.

The changes are in modules/ChangeLog file, briefly i have done:

* Add new option FvwmTaskBarContinuation.  The option allows you specify a
string different to '...'.  Let say, i am using '>'.  It takes less space in a
button field.

* FvwmTaskBarClockFormat could have 'None' value.  Clock could be disabled.

* TaskBar will autohide as soon as another window get a focus.

Your comments are welcome.

Thanks,
Oleg

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 19 Mar 2000 10:16:44 +0100

> 'cvs update; cvs diff >patch_file' command to get it.

Hi Oleg, 
I've tested the patch. Unfortunately, I do not think that we can
apply this patch as it is now.
The main point is that fvwm is under feature freeze. The other point
is that I've got problems with it.
 
> string different to '...'.  Let say, i am using '>'.  It takes less space in a

It is a good idea. Note that the '...' is transformed to '..' or 
'.' or '' if there are some place "problems". Is this taken in acount
in your patch ?

> * FvwmTaskBarClockFormat could have 'None' value.  Clock could be disabled.

It will be very good to get such an option. I've got some pbs with your
patch:
- If I use 
*FvwmTaskBarClockFormat none
*FvwmTaskBarMailCheck 30
Then, the goodies window is no more sucked (Ie, the lines around the
goodies window are no more visible)
- If I do:
*FvwmTaskBarClockFormat none
*FvwmTaskBarClockFormat %R
and *restart* the TaskBar then the clock is not there. I need to
do DestroyModuleConfig FvwmTaskBar* to restore the
default.

> * TaskBar will autohide as soon as another window get a focus.

I think that this must be configurable. I know some users that use 
*FvwmTaskBarAction Click1 iconify off, Focus, Raise
Then, if you click on a button the taskbar lost the focus
and autohide, but the cursor is "on" the taskbar. 
I think that some user may do not like this: some want to use
the task bar to go around all the windows by repeating click 
without having to sometime unhide the taskbar.
 
> Your comments are welcome.

So, my conclusion is that we cannot apply now this patch because we
are in feature freeze. But, after minor fix and improvement I'm
sure that it will be applied to the next devel version (2.5 or 2.9).

Thanks to contribute to fvwm, Olivier

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]