Subject: Bugs found in fvwm 2.3.15, with TkGoodStuff 8.0-final

From: Eric Renfro <[email-masked]>
Date: Fri, 31 Mar 2000 00:40:32 -0600

[FVWM][GetWindowSizeHints]: <<WARNING>> tkgoodstuff window 0x1800062 has broken
Please report this to [email-masked]
flags = 49
min_width = 1024, min_height = 0, max_width = 1009, max_height = 738
width_inc = 1, height_inc = 1
min_aspect = 1/1, max_aspect = 1/1
base_width = 0, base_height = 0   
win_gravity = 1

[FVWM][GetWindowSizeHints]: <<WARNING>> tkgoodstuff window 0x1800062 has broken
Please report this to [email-masked]
flags = 49
min_width = 1024, min_height = 0, max_width = 1009, max_height = 738
width_inc = 1, height_inc = 1
min_aspect = 1/1, max_aspect = 1/1
base_width = 0, base_height = 0   
win_gravity = 1

These are the listed bugs I have found when using tkgoodstuff 8.0 with fvwm
2.3.15, I don't exactly know what this all means, but, I'll include my .tkgrc
for testing purposes:

# tkgoodstuff config file format 1
TKGSet Analog(autoresize) 0
TKGSet Biff(INBOX,listall) 0
TKGSet Biff(INBOX,update_interval) 10
TKGSet Biff(green,image) /usr/share/icons/email-new.xpm
TKGSet Biff(mailer) kmail
TKGSet Biff(nolabel) 1
TKGSet Biff(nomail_image) /usr/share/icons/email-none.xpm
TKGSet Biff(red,image) /usr/share/icons/email-new.xpm
TKGSet Biff(white,image) /usr/share/icons/email-new.xpm
TKGSet Biff(yellow,image) /usr/share/icons/email-new.xpm
TKGSet BiffMH(rcvstore) 0
TKGSet ButtonFileMan(balloon) {Launch File Manager}
TKGSet ButtonFileMan(exec) gentoo
TKGSet ButtonFileMan(imagefile) /usr/share/icons/kfm.xpm
TKGSet ButtonGMasqDialer(exec) {gmasqdialer --no-applet}
TKGSet ButtonGMasqDialer(imagefile) /usr/share/icons/mini/kppp.xpm
TKGSet ButtonGMasqDialer(text) GMasqDialer
TKGSet ButtonQT-MClient(exec) qt-mclient
TKGSet ButtonQT-MClient(imagefile) /usr/share/icons/mini/kppp.xpm
TKGSet ButtonQT-MClient(text) QT-MClient
TKGSet ButtonX-Terminal(balloon) {Launch X-Terminal}
TKGSet ButtonX-Terminal(exec) gnome-terminal
TKGSet ButtonX-Terminal(imagefile) /usr/share/icons/konsole.xpm
TKGSet Buttongkrellm(exec) gkrellm
TKGSet Buttonlicq(exec) {/usr/local/bin/licq -p gtk_gui}
TKGSet Buttonlicq(imagefile) /usr/share/icons/mini/kuser.xpm
TKGSet Buttonlicq(text) licq
TKGSet Clock(border) 2
TKGSet Clock(dside_vert) bottom
TKGSet Clock(orientation) vertical
TKGSet Clock(show) both
TKGSet Ical(activebackground) #9cc29e
TKGSet Ical(activeforeground) #000000
TKGSet Ical(background) #9cc29e
TKGSet Ical(clockbd) 0
TKGSet Ical(foreground) #000000
TKGSet Ical(imagefile) /usr/share/icons/mini/korganizer.xpm
TKGSet Jots(imagefile) /usr/share/icons/mini/klipper.xpm
TKGSet Menu(makebutton) 0
TKGSet Pager(ActiveBackground) #82a884
TKGSet PanelButtonNetwork(imagefile) /usr/share/icons/network_package.xpm
TKGSet PanelButtonUtilities(imagefile) /usr/share/icons/utilities_package.xpm
TKGSet PanelNetwork(iconside) left
TKGSet PanelNetwork(orientation) vertical
TKGSet PanelUtilities(iconside) left
TKGSet PanelUtilities(orientation) vertical
TKGSet Swallowload(exec) {xload -nolabel -update 2 -bg rgb:9c/c2/9e -fg rgb:62/8d/6a}
TKGSet Swallowload(height) 40
TKGSet Swallowload(width) 40
TKGSet TKG(background) #9cc29e
TKGSet TKG(icons) {$TKG(libdir)/icons:/usr/include/X11/pixmaps:/usr/share/icons:/usr/share/icons/mini:/usr/share/icons/large:/usr/share/pixmaps}
TKGSet TKG(orientation) horizontal
TKGSet TKG(panelcolor) #9cc29e
TKGSet TKG(screenedge) bottom
TKGSet WWW(lynx,goto) {rxvt -T lynx -e lynx \$url}
TKGSet WWW(lynx,launch) {rxvt -T lynx -e lynx}
TKGSet WWW(nolabel) 1

-------Configuration-------
Client Pager
Client WindowList
Button X-Terminal
Button FileMan
Client WWW
Client Biff
PanelButton Utilities
Client Menu
Panel Utilities
Client Jots
Client Ical
Button gkrellm
EndPanel
PanelButton Network
Panel Network
Button GMasqDialer
Button QT-MClient
Button licq
EndPanel
Swallow load
Client Clock
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 31 Mar 2000 11:12:15 +0200

On Fri, Mar 31, 2000 at 12:40:32AM -0600, Eric Renfro wrote:
>...
> 2.3.15, I don't exactly know what this all means, ...

This means that tkgoodstuff requested a minimum window width
(1024 pixels) that is larger than the requested maximum width
(1009 pixels).  Although most window managers can handle this
situation, it is a bug in tkgoodstuff.  I think the tkgoodstuff
maintainer is subscribed to this mailing list, so you don't have
to do anything else about this.  You can safely ignore this
message.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 31 Mar 2000 07:30:49 -0500

> to do anything else about this.  You can safely ignore this

In  addition, I believe the min  and max aspect ratios of   1 to 1 are
calling for nothing but square windows.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Fri, 31 Mar 2000 08:21:45 -0500 (EST)

> 2.3.15, I don't exactly know what this all means, but, I'll include my .tkgrc

First off...

tkgoodstuff 8.0-final will not work with Fvwm 2.3 or higher.  This is because
the program relies on the 2.0 module structure which has changed enough in 2.3
to cause incompatibilities.

I had written an upgrade to tkgoodstuff (for fvwm2.2) that added more fvwm
support (mini-icons, etc.).  However, I only found out about the module
structure changes in 2.3 after 2.3 was put into "feature freeze."

My plans now are to incorporate a new module (FvwmTk perhaps) into the next
fvwm release that will compartmentalize the fvwm module information and in
turn call tkgoodstuff (or any other tcl/tk utility) as desired.

Until that happens, tkgoodstuff will work with fvwm2.0 or fvwm2.2, but will
not work properly with fvwm 2.3 or 2.4.

Now... back to the original question:

I'm not exactly sure why the min_width (1024) is smaller than the max_width
(1009) in the size hints...   may I assume that you are using a 1024x768
screen resolution and having tkgoodstuff align on the bottom (or top) of the
screen edge?

-- 
Larry Gensch                                          [email-masked]

                  "May I have ten thousand marbles, please?"

---

From: Dan Espen <[email-masked]>
Date: Fri, 31 Mar 2000 08:21:48 -0500

> 2.3.15, I don't exactly know what this all means, but, I'll include my .tkgrc

Sorry, forgot a conversation from about 2 weeks ago:

http://www.hpc.uh.edu/fvwm/archive/0003/msg00109.html

Right now, tkgoodstuff won't work with the latest betas.

---

From: Eric Renfro <[email-masked]>
Date: Fri, 31 Mar 2000 16:16:53 -0600

> screen resolution and having tkgoodstuff align on the bottom (or top) of the

Well, I've been using TkGoodstuff for, well, eons. I still use it in fvwm
2.3.15, but just get that one little error now since 2.3.x. In fact, I don't
remember seeing it until I started swallowing xload into the panel.

But, the FvwmTk module sounds like an idea. I'm making an fvwm-themer engine,
in attempt to have a nice "themable" easy interface setup, and to have
fvwm.themes.org get reborn with it (hopefully!).

And yes, I'm using 1024x768 and tkgoodstuff is at the bottom., in fact, I have
a screenshot of my current configuration on my fvwm-themer page:
http://myrddincon.dynup.net/projects/fvwm-themer/

Eric Renfro <Psi-Jack>

---

From: Alex Wallis <[email-masked]>
Date: Sat, 01 Apr 2000 16:03:41 +0930

> http://myrddincon.dynup.net/projects/fvwm-themer/
Mikhael Goikhman And Olivier Chapuis, two developers from this list,
have been writing a perl-script based theme tool called
fvwm-themes-config which can be downloaded from
https://sourceforge.net/project/?group_id=1738

It appears likely that this new themes package is going to be featured
on the soon to be recreated fvwm.themes.org page. However more people
are needed to help with bug-testing and adding additional features to
this project. All input is being welcomed. Currently a recent snapshot
of fvwm or the cvs sources are required.

There is also a mailing list for fvwm themes.
FVWM-Themes-devel <[email-masked]>

As an extra note: I think 2.5M is somewhat large and discouraging to
potential users for downloading over modem dial-up connections. The
above mentioned package is under 300K.

I myself have an fvwm themes configuration suite of forms available at
http://www.dove.net.au/~awol/fvwm2/ (bug-ridden pre-alpha only) which I
have 
just begun reworking to hopefully integrate into a full-featured
user-friendly interface to fvwm-themes-config. (It's only 81K)

There are also several other themes designers and packages available,
and I refer you to this lists mail archives for details on them.

Email for fvwm.themes.org can be directed to 
Charlie Schmidt         [email-masked]
as he has been the main contact for that organisation.

Jason Kibblewhite and myself have created channel #fvwm on EFNET irc for
online realtime discussions on themes and any other fvwm matters.
Everybody welcome!  :)

I hope this email helps.

Alex

"If you're not part of the solution, you're part of the precipitate."