Subject: BorderStyle Solid color option

From: Olivier Chapuis <[email-masked]>
Date: Sun, 19 Mar 2000 11:33:06 +0100

Hello,
IMHO the fact that there are no Solid option to BorderStyle
so that the shadow and hilight colors are computed from *this
solid color* is a "feature bug" of fvwm.

Why ? because fvwm cannot do in a good way a window with 
different colors for the title and the border.
Let us take an example:
I would like grey80 for the border of active or inactive
windows, DarkBlue for the bg of the title (and buttons) 
of active windows, grey51 for the bg of the title (and 
buttons) of inactive windows, and a white fg for the the 
title of active and inactive windows (typical fvwm95 colors).

I think the better thing I can do is:

# the color of the border and the fg of the titles
Style "*"	ForeColor white, BackColor grey80
Style "*"	HilightFore white, HilightBack grey80

# color for the title
TitleStyle	ActiveUp   solid DarkBlue
TitleStyle	ActiveDown solid DarkBlue
TitleStyle	Inactive   solid grey51

# The colors for the background of the buttons.
ButtonStyle All  ToggledActiveUp   Solid DarkBlue
ButtonStyle All  ToggledActiveDown Solid DarkBlue
ButtonStyle All  ToggledInactive   Solid grey51

And this leads to a number of problems:
* The icon titles are almost not readable (the colors are taken 
from Style "*"	ForeColor ...)
* The automatic colors of the pager are bad (the colors are taken 
from Style "*"	ForeColor ...).
* With a Raised or Sunk TitleStyle the stuff is horible 
(the hi and sh colors are taken from Style "*"	ForeColor ...)

If we have a Solid option to BorderStyle so that the shadow and 
hilight colors are computed from *this solid color*, then all these
problems can be fixed easely :)

I've take a look to borders.c, but I do not know if this is 
difficult to do or/and if this can break some stuff. 
Dominik, with the time you pass on the border code I'm sure that 
you can quikly have an opinion (?) and may be do something if
nobody is against this ?

Regards, Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 24 Mar 2000 13:36:25 +0100

> you can quikly have an opinion (?) and may be do something if

Urks, do you really think I'm the BorderStyle expert? Shudder!
No sorry, I don't know what to do, but I guess it's not so
difficult.  On the other hand, if the plan is to remove all
the ...Style commands (except Style and MenuStyle) after 2.4,
if may be not so useful to do now.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 24 Mar 2000 17:30:15 +0100

> Urks, do you really think I'm the BorderStyle expert? Shudder!

Hum, Hum, almost all the recent commit on borders.c has been
done by ... domivogt. I remembered also discussions between you,
Tim and others about border look. Tim any opinion about this
"border bug" ?

> if may be not so useful to do now.

Ok, but how many times we have to wait before 2.6 (or 3.0) ?
Also this story of border is really stupid: we cannot use
colorset for Title in fvwm-themes because we want a redmond98
theme (so we need to have different colors for the title and the 
border). Also, systeme.fvwm2rc-sample-95 suffers the same pb. and
it is not a good colors example for a sample (yes I still work on
this stuff).

So, if no body want to do it (this solid option) and if I get 
3/2 votes (I consider Dominik answer as a 1/2 vote, since it
says that the stuff is easy and do not give a formal objection) 
and no objection I will do it.

Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 25 Mar 2000 04:53:13 +0200

> Style "*"	HilightFore white, HilightBack grey80

Yes, this is a very bad emulation (although others are yet worse).
White on gray is unreadable and 2 backgrounds should be different.

> problems can be fixed easely :)

I.e. you propose to add additional BorderStyle Solid option, and when it
presents, to evaluate the shadow and hilight colors from it and not from
background color (or colorset). So a better name of this BorderStyle
option is BackColor or/and BackColorset. And you say the fore color is
used from other place (ForeColor/HilightFore or Colorset/HilightColorset).

Is not it more clear to have 2 additional style options BorderColorset
and BorderHilightColorset in addition to Colorset and HilightColorset.
If the first pair is defined, it is used instead the second pair for
borders. The second pair is always used for titles, icon titles, pager.

Regards,
Mikhael.

---

From: Tim Phipps <[email-masked]>
Date: Mon, 27 Mar 2000 10:22:19 +0100

> different colors for the title and the border.

I agree but I think the problem is inability to set the text color for
titles.

`Style "*" color fg bg' is probably doing to much. It sets the border
and icon background color to bg and the icon and title text color to fg.
I think it shouldn't set the title text color, which implies I think we
need a TitleColor style command.

TitleStyle lets you set the background but won't let you change the text
or relief colors.

I'd like to nuke BorderStyle, ButtonStyle and TitleStyle and move the
functionality into the style command with some tweaks to make things
simpler, but it would break backward compatibility and I can't see how
to emulate AddTitleStyle's ability to stack multiple pixmaps in the
titlebar.

Cheers,
Tim.

---

From: Tim Phipps <[email-masked]>
Date: Mon, 27 Mar 2000 10:24:40 +0100

> and no objection I will do it.

I vote against, I'd rather get 2.4 out and then do it thoroughly.

Cheers,
Tim.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 29 Mar 2000 13:27:07 +0200

> I vote against, I'd rather get 2.4 out and then do it thoroughly.

I hope you only voted against BorderStyle Solid, and not against solving
the problem. :)  It is bad if fvwm 2.4 does not support such windows,
especially if there is a simple, in my opinion, fix, see another message.

Regards,
Mikhael.

---

From: Tim Phipps <[email-masked]>
Date: Wed, 29 Mar 2000 12:43:21 +0100

Mikhael Goikhman wrote:
> the problem. :)

Correct, I'd like to remove
titlestyle/borderstyle/buttonstyle/buttonstate and decors and move the
functionality into the style command.

Cheers,
Tim.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 29 Mar 2000 13:47:18 +0200

> to emulate AddTitleStyle's ability to stack multiple pixmaps in the

Yes, a titlebar is not easy, but a border has no stack ability, only one
colorset is used. I prefer to speak colorsets, because they are left after
2.4, and this can't be said about other color options.

After learning many themes, Olivier and I got to the conclusion that it is
ok for Colorset/HilightColorset to be responsible for title colors, icon
title colors and default pager colors. It is not ok however for them to be
responsible for border colors in some themes (not all). So to support
these windoze-like, afterstep-like and so on themes I propose to add 2 new
styles options: BorderColorset and BorderHilightColorset, which (when set)
will overwrite the Colorset/HilightColorset definition for borders.

The actual color code is already in, it is only to add 2 style options
and use another colorset if defined. This is something, which, is useful
after 2.4, because it could replace BorderStyle [In]active TiledPixmap.

I and Olivier are willing to add these 2 style options.
We need a one additional vote and no votes against.

Regards,
Mikhael.

---

From: Tim Phipps <[email-masked]>
Date: Wed, 29 Mar 2000 13:00:39 +0100

> We need a one additional vote and no votes against.

Fair enough then, I withdraw my no vote.

Cheers,
Tim.

---

From: Dan Espen <[email-masked]>
Date: Wed, 29 Mar 2000 08:15:23 -0500

> We need a one additional vote and no votes against.

OK.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 29 Mar 2000 17:48:56 +0200

> > We need a one additional vote and no votes against.

What style option do you have in mind?  I'm against new
graphical options that are not implemented via colour sets.

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 29 Mar 2000 19:52:35 +0200

> Fair enough then, I withdraw my no vote.

Very well, I'll not vote for or against it.  Just one completely
unrelated request:  I have trouble with the mail connection from
my work address.  The effect is that I receive list mails completely
out of order (some mails take minutes to arrive, others take hours).
All I ask for are a few more lines of context in replies so that I
can participate in the discussion.  This explains some stupid replies
from me too.

Bye

Dominik ^_^