Subject: Re: Notification: incoming/580

From: Dominik Vogt <[email-masked]>
Date: Fri, 17 Mar 2000 09:59:21 +0100

On Tue, Mar 07, 2000 at 06:59:47PM +0100, Non-HP-nzanella wrote:
> 
> 
> On 7 Mar 2000, Paul D. Smith wrote:
> 
> > %% [email-masked] writes:
> > 
> >   f> I have pine 4.10, XFree86 3.3.2 with XFree86 xterm, Fvwm 2.3.15
> > 
> >   f> - I launch the pine mail program in an xterm.
> >   f> - I maximize xterm with the fvwm2 builtin Maximize function.
> >   f> - pine behaves correctly and adjusts to the new window size
> >   f> - but now, I right click to change the font to a smaller one
> >   f> - the xterm is blanked out for a few seconds, then pine reappears
> >   f>   occupying only part of the screen (incorrectly).
> > 
> >   f> I repeat the experiment without pine:
> > 
> >   f> - I launch an xterm.
> >   f> - echo $LINES (output: just '\n', as I noted in another e-mail,
> anyway...)
> >   f> - I maximize xterm with the fvwm2 builtin Maximize function.
> >   f> - echo $LINES (output: 43)
> >   f> - change font to "Tiny" (output: 43 ... wrong!)
> >   f> - Minimize and then Maximize with fvwm2 builtin Maximize
> function.
> >   f> - echo $LINES (output: 80 ... right!)
> > 
> > Seems more like an xterm bug than fvwm.

It *is* an xterm bug.  xterm illegally assumes that the window
manager will honour its request to resize the window when it
changes its font size.

> > Does it work right if you use a different window manager?
> 
> Well, I just tried it under KDE and what KDE did was readjust the size
> of the window when I changed the font through xterm's CTRL-Right mouse
> button. So yes, it did behave correctly.

In my eyes this isn't right either.  If the window is maximised it's
maximised.  Since the user explicitly asked for this, the WM should
assume that (s)he wants a full screen window regardless of the font
size.

There is a workaround though.  Instead of maximising the window,
move it to 0 0 and resize it 'manually':

  Move 0 0
  Resize 100 100

Then you will get the desired behaviour without noticing the
difference (of course you can't toggle the window state then).

> > Does it work right if you use, say, the latest rxvt instead of xterm?
> 
> As far as I know rxvt does not have the builtin right mouse click
> mechanism that xterm has.

Right.  This won't happen with rxvt.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Neil Zanella <[email-masked]>
Date: Fri, 17 Mar 2000 13:45:13 -0330 (NST)

> move it to 0 0 and resize it 'manually':

Nice. Can I have a similar scheme for maximizing vertically. I don't
know how I would put the following idea into fvwm's syntax:

$x = x-position of window
Move $x 0
Maximize 100 0

Thanks,

Neil

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 17 Mar 2000 17:12:00 -0500

> $x = x-position of window

AddToFunc "VMax" "I" Move w 0
AddToFunc "VMax" "I" Maximize 0 100

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]