Subject: Re: Again - FvwmPager & StaysOnTop (PR-543)

From: Nadim Shaikli <[email-masked]>
Date: Wed, 22 Mar 2000 11:10:44 -0800 (PST)

On Tuesday - March.14.2000 [16:13:52 +0000],
 Tim Phipps ([email-masked]) wrote:
 > Nadim Shaikli wrote:
 > > BTW: could someone add the layer info to 'FvwmIdent' (it would help
 > > debug) ??
 > >
 > Done, let us know how you get on.
 >
 > CHeers,
 > Tim.

Thanks Tim.  Well the problem reared its ugly head again this morning (its
been on hiatus for the past week or so :-).  I did an 'FvwmIdent' on the pager
before the problem occurred and after; the results was identical (I'll attach a
shot of it).  Oddly, the xterm has a Layer of 4 noted where-as the pager has a
Layer of 6, yet still the xterm covers the pager (I'll attach a shot of the
xterm's FvwmIdent as well).

Any ideas on why this is happening ?

 + fvwm-snap-20000315
 + SunOS chico 5.7 Generic_106541-08 sun4u sparc SUNW,Ultra-60

Thanks for the help

 - Nadim

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 24 Mar 2000 14:11:03 +0100

On Wed, Mar 22, 2000 at 11:10:44AM -0800, Nadim Shaikli wrote:
Content-Description: message body text
>  + SunOS chico 5.7 Generic_106541-08 sun4u sparc SUNW,Ultra-60

Next time when this happens, first write down the FvwmWindow structures
of the two windows.  Then kill fvwm with 

  kill -6 <fvwm's process id>

This will generate a core dump.  Fire up a good graphical
debugger and print out the stacking order chain.  Beginning
from Scr.FvwmRoot.stack_next follow write down the stack_next
and stack_prev pointers.  If the problem is within the stacking
order you will notice that the two windows have the wrong order.
Try to dump all FvwmWindow structures into a file so I can see
what's wrong.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]