Subject: Patch for ActiveColorset

From: Darren Stuart Embry <[email-masked]>
Date: Thu, 3 Feb 2000 01:09:58 -0500

This little patch against fvwm-2.3.13 fixes a problem where
ActiveColorset would not work properly unless HilightBack and
ActiveFore were set.  I even added a ChangeLog entry this time.
:)

Darren

-- 
Darren Stuart Embry.  Can you dig it?
http://www.slug.louisville.edu/~dsembr01/
        ``Uh-huh... womp!  Uh-huh... yeah!''
	  -- The Moog Cookbook's cover of R.E.M.'s ``The One I Love''
diff -cbrB fvwm-2.3.13.ORIG/ChangeLog fvwm-2.3.13/ChangeLog
*** fvwm-2.3.13.ORIG/ChangeLog	Sun Jan 23 10:04:36 2000
--- fvwm-2.3.13/ChangeLog	Thu Feb  3 00:57:16 2000
***************
*** 1,3 ****
--- 1,10 ----
+ 2000-02-03  Darren Stuart Embry  <[email-masked]>
+ 
+ 	* fvwm/menus.c (paint_item):
+ 	* fvwm/menus.c (NewMenuStyle): 
+ 	fixed ActiveColorstyle for menus; would not work without also
+ 	setting HilightBack and ActiveFore.
+ 
  2000-01-23  Dominik Vogt  <[email-masked]>
  
  	* libs/System.c (getFileStamp):
diff -cbrB fvwm-2.3.13.ORIG/fvwm/menus.c fvwm-2.3.13/fvwm/menus.c
*** fvwm-2.3.13.ORIG/fvwm/menus.c	Thu Jan 20 18:11:12 2000
--- fvwm-2.3.13/fvwm/menus.c	Thu Feb  3 00:49:10 2000
***************
*** 3030,3037 ****
--- 3030,3039 ----
    {
      currentGC = (is_item_selected) ?
        MST_MENU_ACTIVE_GC(mr) : MST_MENU_GC(mr);
+ 
      if (MST_DO_HILIGHT(mr) &&
  	!MST_HAS_ACTIVE_FORE(mr) &&
+ 	!MST_HAS_ACTIVE_CSET(mr) &&
  	is_item_selected)
      {
        /* Use a lighter color for highlighted windows menu items if the
***************
*** 5966,5971 ****
--- 5968,5974 ----
  	AllocColorset(*val);
        }
        has_gc_changed = True;
+       ST_DO_HILIGHT(tmpms) = 1;
        break;
      case 48: /* GreyedColorset */
        if (GetIntegerArguments(args, NULL, val, 1) == 0 || *val < 0)

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 3 Feb 2000 15:17:50 +0100

> ActiveFore were set.  I even added a ChangeLog entry this time.

Thanks for the patch, I've applied it (with a fix in the second part).

Bye

Dominik ^_^

                                ^^^

This must be set to 0 when the activecset is deactivated
(i.e. called without arguments).

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]