Subject: Core dump with my 2.2 config file

From: Dan Espen <[email-masked]>
Date: Thu, 10 Feb 2000 08:43:21 -0500

This morning, I  tried to run the current  CVS with the config file  I
used to use for 2.2.  Part of the config  file included a Recapture to
make a  style/decor change  active.   This now  produces the following
stack:

(gdb) where
#0  0xef61fe90 in XDrawSegments () from /usr/lib/libX11.so.4
#1  0x88734 in RelieveRectangle (dpy=0xb0840, d=0, x=0, y=0, w=9, h=18, 
    ReliefGC=0x0, ShadowGC=0x0, line_width=2)
    at ../../version-2_3_14/libs/Graphics.c:48
#2  0x34cbc in DisplayPosition (tmp_win=0xf0918, x=400, y=516, Init=1)
    at ../../version-2_3_14/fvwm/move_resize.c:1289
#3  0x336e8 in moveLoop (tmp_win=0xf0918, XOffset=0, YOffset=0, Width=1280, 
    Height=1030, FinalX=0xefffc110, FinalY=0xefffc10c, do_move_opaque=0, 
    AddWindow=1) at ../../version-2_3_14/fvwm/move_resize.c:928
#4  0x76a50 in PlaceWindow (tmp_win=0xf0918, sflags=0xefffc2d4, Desk=0, 
    PageX=0, PageY=0, mode=0) at ../../version-2_3_14/fvwm/placement.c:753
#5  0x502f0 in setup_window_placement (tmp_win=0xf0918, pstyle=0xefffc278)
    at ../../version-2_3_14/fvwm/add_window.c:570
#6  0x527e0 in AddWindow (w=54525955, ReuseWin=0x0)
    at ../../version-2_3_14/fvwm/add_window.c:1372
#7  0x4b7d8 in HandleMapRequestKeepRaised (KeepRaised=0, ReuseWin=0x0)
    at ../../version-2_3_14/fvwm/events.c:1072
#8  0x568c4 in CaptureAllWindows () at ../../version-2_3_14/fvwm/fvwm.c:904
#9  0x40864 in do_recapture (eventp=0xae4ec, w=40, tmp_win=0x0, context=8, 
    action=0xda239 "", Module=0xefffc6e4, fSingle=0)
    at ../../version-2_3_14/fvwm/builtins.c:2291
#10 0x40924 in Recapture (eventp=0xae4ec, w=40, tmp_win=0x0, context=8, 
    action=0xda239 "", Module=0xefffc6e4)
    at ../../version-2_3_14/fvwm/builtins.c:2310
#11 0x6a2f0 in ExecuteFunction (Action=0xda2d8 "Recapture", tmp_win=0x0, 
    eventp=0xae4ec, context=8, Module=-2, expand_cmd=EXPAND_COMMAND)
    at ../../version-2_3_14/fvwm/functions.c:856
#12 0x6b5b8 in execute_complex_function (eventp=0xae4ec, w=0, tmp_win=0x0, 
    context=8, action=0xda290 "DecorCustom\n", Module=0xefffc904, 
    desperate=0xefffc844, expand_cmd=DONT_EXPAND_COMMAND)
    at ../../version-2_3_14/fvwm/functions.c:1328
#13 0x6a32c in ExecuteFunction (Action=0xefffc918 "DecorCustom\n", 
    tmp_win=0x0, eventp=0xae4ec, context=8, Module=-1, 
    expand_cmd=EXPAND_COMMAND) at ../../version-2_3_14/fvwm/functions.c:862
#14 0x87bcc in run_command_stream (f=0xae8e0, eventp=0xae4ec, tmp_win=0x0, 
    context=8, Module=-1) at ../../version-2_3_14/fvwm/read.c:81
#15 0x87e34 in run_command_file (filename=0xb2e10 "/u/dane/.fvwm2rc", 
    eventp=0xae4ec, tmp_win=0x0, context=8, Module=-1)
    at ../../version-2_3_14/fvwm/read.c:154
#16 0x55c64 in main (argc=1, argv=0xefffd27c)
    at ../../version-2_3_14/fvwm/fvwm.c:635
(gdb)

This happens during start up.  The window being placed is an rxvt.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 10 Feb 2000 15:00:30 +0100

>     ReliefGC=0x0, ShadowGC=0x0, line_width=2)
      ^^^^^^^^^^^^^^^^^^^^^^^^^^
>     at ../../version-2_3_14/fvwm/move_resize.c:1289

This is called before Scr.StdReliefGC and Scr.StdShadowGC are set.
Because of the 'Style change w/o recapture' patch this is done only
after the config file has been read.  I think I've fixed it.  Just
wait for my next commit.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]