Subject: Desktop icon whoos

From: Joerg Klemenz <[email-masked]>
Date: Sat, 26 Feb 2000 14:04:25 +0100

I finally found a way to repeat at leat partially a bug that has
annoyed me for some time.
Sometimes when I iconify a window the icon gets "trapped" under an other
icon that already exists on the desktop.

OK, this is how to make the bug happen (3 bugs actually):
I use style * SloppyFocus, StickyIcon, IconBox at bottom at screen

I have 3 icons from left 2 right at bottom of screen (a b c).
I do a window manager reset
move pointer over the icons and the color of the title
  does *not* change to the active colorset
Then de-iconify icon b
go to other page
icons do *not* get re-sorted like before the wm reset
  a "hole" exist in the middle
start any app (x), iconify, it takes the place in the middle
now: go back to prev page 
iconify the "b" app, and whoo.. it gets trapped under the "x" icon

I use a version 2.3.15 build from CVS
BTW I did a CVS update yesterday but did not install it, looked broken
to me. Whats up w/ the version number 2.3.25?? 

-- 
joerg klemenz     According to the latest official figures, 43% 
[email-masked]     of all statistics are totally worthless. 
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 28 Feb 2000 12:16:23 +0100

> to me. Whats up w/ the version number 2.3.25??

That's an effect of my new version of the make_fvwmdist.sh
script.  I forgot to fix up the version number on Friday.
I'll commit a fix.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 28 Feb 2000 12:46:05 +0100

Hm, I can't verify anithing you say:
> I do a window manager reset move pointer over the icons and
> the color of the title does *not* change to the active colorset

Works for me.

> Then de-iconify icon b go to other page icons do *not* get
> re-sorted like before the wm reset a "hole" exist in the middle

Nope, no hole for me; the icons are properly resorted.

> now: go back to prev page iconify the "b" app, and whoo..
> it gets trapped under the "x" icon

... no hole -> no overlapping

Can you provide a minimal config that shows your problem?

Bye

Dominik ^_^

---

From: Joerg Klemenz <[email-masked]>
Date: Tue, 29 Feb 2000 18:09:35 +0100

> Can you provide a minimal config that shows your problem?

Here it comes