Subject: Notification: incoming/564

From: [email-masked]
Date: Sun, 13 Feb 2000 13:00:47 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/564

Message summary for PR#564
	From: [email-masked]
	Subject: GrabFocus and GPM
	Date: Sun, 13 Feb 2000 13:00:45 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Michael Han <[email-masked]>
Date: Sun, 13 Feb 2000 21:20:15 -0800

Previously from [email-masked]
>I am using the GrabFocus feature that causes newly mapped window to grab
>the
>focus. Things work fine except for GPM (the cut and paste utility):
>
>- I cut some text with the first mouse button.
- I place the X cursor on top of a first xterm.
>- I launch a second xterm through a keyboard binding. The mouse cursor
>  is still on top of the first xterm and not on top of the second which
>  grabs the focus via the GrabFocus configuration option.
>- Now typing send characters to the second xterm which is fine but pasting
>  with the middle mouse button sends the stuff to the first xterm. This
>  behavior is rather unexpected. Pasting should send the text to the xterm
>  which has the focus.

What's your focus policy? It looks like ClickToFocus. If so, are you
using ClickToFocusPassesClick (default)? Whatever the case, your click
to paste may be getting muddled by the focus policy.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
"And, just like it should in all stories about philosophers, it ended
up in complete chaos." - Richard P. Feynman
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Neil Zanella <[email-masked]>
Date: Mon, 14 Feb 2000 13:36:27 -0330 (NST)

> to paste may be getting muddled by the focus policy.

My focus policy is SloppyFocus with Style * GrabFocus

My complete .fvwm2rc file is available at:

http://www.cs.mun.ca/~nzanella/computing/fvwm2/system.fvwm2rc

All I have to do is pop up xterm, cut, pop up xterm, paste.
The stuff gets pasted to the original window which the pointer
is on top of.

Neil

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Feb 2000 10:06:20 +0100

> The stuff gets pasted to the original window which the pointer

I can confirm that this happens.  I'm not sure why, though.
Probably it's the fault of X, but I'm not sure yet.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]