Subject: FvwmButton Panel question

From: "Robert H. Ford II" <[email-masked]>
Date: Fri, 18 Feb 2000 14:48:31 -0600

The problem I am (actually a user on my system is having) is described in three
examples below.

I have a vertical buttonbar with panels defined (example 1 - "P" denotes a
panel) displayed on a 17 inch monitor.

 ___
|   | -------\
|___|         \
|   |          \
|___|           \
|   |            \
|___|             \______ (swallowed pager)
|   |             /
|___|            /
|   |           /
|___|          /
|   |         /
|___| _______/
| P |
|___|
|   |
|___|
| P |
|___|
| P |
|___|
| P |
|___|
(EXAMPLE 1)

When I click on the panel button the panel opens on the far right of the screen
(example 2 - pr is pressed panel) before re-aligning its self correctly (example
3 - pr is pressed panel)

 ___
|   | -------\
|___|         \
|   |          \
|___|           \
|   |            \
|___|             \______ (swallowed pager)
|   |             /
|___|            /
|   |           /
|___|          /
|   |         /
|___| _______/           ___ ___ ___ ___ ___
| P |                   |   |   |   |   |   |
|___|                   |___|___|___|___|___|
|   |
|___|
| P |
|___|
| pr|
|___|
| P |
|___| 
(EXAMPLE 2)

 ___
|   | -------\
|___|         \
|   |          \
|___|           \
|   |            \
|___|             \______ (swallowed pager)
|   |             /
|___|            /
|   |           /
|___|          /
|   |         /
|___| _______/
| P |
|___|
|   |
|___|
| P |
|___|___ ___ ___ ___ ___
| pr|   |   |   |   |   |
|___|___|___|___|___|___|
| P |
|___|
(EXAMPLE 3)

My question is what could be causing this problem.  I run a similar config file
on the same platform with the same compiled version of fvwm2 and its modules on
a 19 inch screen with no problems.  The only differences between the 17 inch and
19 inch settings are some geometry locations.

======================================================================

Here are the line in the $HOME/.fvwm2rc file:

###################### Button button-bar Files #######################
# FvwmButtons Configuration file
*FvwmButtonsFile /home/misha21/.fvwm/Buttons
*MainPanelFile /home/misha21/.fvwm/MainPanel
*LoginsPanelFile /home/misha21/.fvwm/LoginsPanel
*AppsPanelFile /home/misha21/.fvwm/AppsPanel
*ArtToolsPanelFile /home/misha21/.fvwm/ArtToolsPanel
*LabToolsPanelFile /home/misha21/.fvwm/LabToolsPanel

======================================================================

======================================================================

Here are the contents of the FvwmButtons file:

Fore rgb:ff/ff/ff
Pixmap ASBBlockBlue.xpm
Back rgb:64/62/94
Geometry +0+92
ButtonGeometry 65x65
Columns 1
BoxSize fixed
Font -*-helvetica-medium-r-*-*-12-*
Padding 0 0

(1x6,Swallow "FvwmPager" 'FvwmPager 0 5')
(Icon fvwm4.xpm, Panel(right, delay 0, steps 2) MainPanel \
"Module FvwmButtons -transientpanel MainPanel")
(Center,NoSize,Icon monitor-e0.xpm,Action \
        'Exec "ihgp138x31"  exec xterm -title ihgp138x31 -bg antiquewhite -fg bl
ack -bd magenta4 &', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(NoSize,Icon hostmanager.xpm,Action "Function Find-or-Start tkrl")
(NoSize, Icon Monitor.xpm, Panel(right, delay 0, steps 0) LoginsPanel, \
        "Module FvwmButtons -transientpanel LoginsPanel")
(NoSize,Icon tool.xpm, Panel(right, delay 0, steps 0) AppsPanel, \
        "Module FvwmButtons -transientpanel AppsPanel")
(NoSize,Icon Gandalf48x48.xpm, Panel(right, delay 0, steps 2) ArtToolsPanel, \
        "Module FvwmButtons -transientpanel ArtToolsPanel")

======================================================================

======================================================================

Here are the contents of one of the Panel files:

Fore rgb:ff/ff/ff
Pixmap ASBBlockBlue.xpm
Back rgb:64/62/94
Geometry +65+742
ButtonGeometry 65x65
Rows 1
BoxSize fixed
Font -*-helvetica-medium-r-*-*-12-*
Padding 0 0

(Icon netscape4.xpm,Action 'Function Find-or-Start Netscape')
(Icon NScal.xpm,Action 'Function Find-or-Start NetscapeCalendar')
(Icon calc.xpm,Action 'Function Find-or-Start calctool')
(Icon OldFashionedRadio.xpm,Action 'Function Find-or-Start audiocontrol')
(Title xfontselect,Icon a-z.xpm,Action 'Function Find-or-Start xfontsel', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Title xcolorselect,Icon Brush.xpm,Action 'Function Find-or-Start xcolorsel', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Icon pilotmanager.xpm,Action 'Function Find-or-Start PilotManager')
(Title Answerbook,Icon Info.xpm,Action 'Exec "answerbook" exec answerbook &', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Title Xmcd,Icon CDrom.xpm,Action 'Function Find-or-Start xmcd', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Title JMM,Icon jmm.xpm,Action 'Function Find-or-Start VendorShell', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Swallow(UseOld,NoKill) "Perfmeter" "Exec perfmeter -d -t cpu -bg DarkSlateBlue 
-fg white &")

======================================================================

Any help would be greatly appreciated.

-- 
    _/_/_/     _/  _/   _/_/_/_/   _/_/_/_/_/_/ Robert H. Ford II
   _/   _/    _/  _/   _/           _/    _/    Lucent Technologies
  _/_/_/     _/_/_/   _/_/_/       _/    _/     Bell Labs Innovations
 _/   _/    _/  _/   _/           _/    _/      Naperville IL, 60566-7045
_/    _/   _/  _/   _/         _/_/_/_/_/_/     mailto:[email-masked]
                                                Voice: (630) 713-4957
__________________________________________________
|  M R spiders!                    |      |   |  |
|  M N O spiders!                  |      |   |  |
|  O S A R - C D E D B D I's?      |      |   |  |
|  Y I B, M R spiders...           |      |   *  |
|                                  *      |      |
|                                         *      |
--------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 21 Feb 2000 13:08:22 +0100

> The problem I am (actually a user on my system is having) is described in three

...

> Any help would be greatly appreciated.

If you can make a single .fvwm2rc file that I can use to
reproduce the problem I'll see if that's a bug or a feature :-)

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]