Subject: Transparency support

From: Tim Phipps <[email-masked]>
Date: Fri, 18 Feb 2000 09:52:27 +0000

Hi listees,
	Transparent colorset support for modules is still broken. It needs a
new style flag to fix it.  Should I do it?

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 18 Feb 2000 11:16:38 +0100

> new style flag to fix it.  Should I do it?

Hi Tim, good that you post this again - I knew someone asked
for help introducing a new style flag, but I couldn't remember
who and why.  A style flag is probably a good solution here
and I'd volunteer to help with the flag implementation details
if you want.  If you'd like to try implementing a style flag
yourself, here's a list of the files you'll have to touch and
what to do in them:

fvwm.h             add the style flag
style.c            modify ProcessNewStyle() and check_window_style_change()
style.h            access macros for the new style flag
window_flags.h     access macros for the new window flag (if necessary)
add_window.c       write/modify setup_/change_/destroy_... functions
add_window.h       export new functions if needed
update.c           handle style changes in flush_window_updates() and
                   apply_window_updates()
update.h           introduce new change flag if necessary
NEWS               ...
fvwm2.1            ...

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]