Subject: Re: FvwmIconMan doesn't clear when windows close

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Feb 2000 10:05:07 +0100

On Thu, Jan 27, 2000 at 11:22:44AM +0000, [email-masked] wrote:
> Configuration Information [Automatically generated, do not change]:
> uname output: SunOS tazmo 5.6 Generic_105181-15 sun4u sparc SUNW,Ultra-4
> Compiler: gcc
> Compilation CFLAGS: -g -O2
> prefix: /home/tim
> sysconfdir: /home/tim/etc
> libexecdir: /home/tim/libexec
> 
> FVWM Version: 2.3.14
> FVWM_CONFIGDIR: unset
> FVWM_MODULEDIR: /home/tim/libexec/fvwm/2.3.14
> FVWM_USERHOME: /home/tim/.X
> 
> Description:
> 	This may be to do with the changes to make FvwmIconMan support
> 	transparency.  With a very simple config FvwmIconMan does not
> 	clear the empty part of its main window when a button should
> 	go away.
> 
> Repeat-By:
> 	This is the config:
> 
> *FvwmIconMan*ButtonGeometry 100x0
> *FvwmIconMan*ManagerGeometry 4x0
> 
> Start with less than three windows on the screen and start FvwmIconMan.
> It creates a one line window that looks shaped but is in fact 4x1 buttons
> with a transparent part.  Create some new windows and FvwmIconMan will
> create a new row of buttons. The second row has a black background.
> When there are two buttons on the second row close a window. FvwmIconMan
> does not clear the last button but leaves it there so it looks like
> there are still two buttons on the bottom row.

Tim, is this problem resolved or are there any glitches left?

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Wed, 16 Feb 2000 13:15:27 +0000

> Tim, is this problem resolved or are there any glitches left?

Yes thanks.