Subject: CVS hippo: Documented that CleverPlacement has to come after SmartPlacement

From: CVS <[email-masked]>
Date: Wed, 2 Feb 2000 07:43:58 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	hippo	00/02/02 07:43:57

Modified files:
	fvwm           : fvwm2.1 

Log message:
Documented that CleverPlacement has to come after SmartPlacement

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 2 Feb 2000 15:34:09 +0100

> Documented that CleverPlacement has to come after SmartPlacement

But that's wrong.  The CleverPlavement flag can be set before
the SmartPlacement flag.  It has no effect then, though.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Wed, 02 Feb 2000 14:46:43 +0000

> the SmartPlacement flag.  It has no effect then, though.

Bad choice of log message, it now reads:

          CleverPlacement augments the  SmartPlacement  style  so
          that  it  tries to avoid overlapping icons, sticky win-
          dows and windows on higher layers.   If  SmartPlacement
          is  not used, CleverPlacement has no effect.  To switch
          this style off again, use the CleverPlacementOff style.
          CleverPlacement  must  be specified after SmartPlacment
          to take effect.

Is this accurate?
Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 2 Feb 2000 16:56:38 +0100

>           CleverPlacement  must  be specified after SmartPlacment

No.  The order in which this is specified does not matter.
You can use

  Style * SmartPlacement, CleverPlacement

as well as

  Style * CleverPlacement, SmartPlacement

or even

  Style * CleverPlacement
  Style foo bar
  Style * SmartPlacement

I tried hard to make it work exactly like with the old global
option so that config files don't have to be changed.
Specifying DumpPlacement will void the CleverPlacement flag,
though.

Bye

Dominik ^_^

---

From: Tim Phipps <[email-masked]>
Date: Wed, 02 Feb 2000 16:09:17 +0000

I think we have a bug

>   Style * CleverPlacement, SmartPlacement
This works OK

>   Style * SmartPlacement
This doesn't, it looks just like SmartPlacement i.e. it switches to
DumbPlacement if it can't find an empty space to put the window.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 2 Feb 2000 17:46:54 +0100

> DumbPlacement if it can't find an empty space to put the window.

Fixed.

Bye

Dominik ^_^