Subject: Notification: incoming/568

From: [email-masked]
Date: Mon, 14 Feb 2000 02:59:15 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/568

Message summary for PR#568
	From: [email-masked]
	Subject: enhancement: styles tied to window id
	Date: Mon, 14 Feb 2000 02:59:14 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Joerg Klemenz <[email-masked]>
Date: Tue, 15 Feb 2000 22:49:46 +0100

[email-masked] (Mon, 14 Feb 2000):
> To allow control over individual window styles it should be
> possible to use a window id as the style reference.  The style
> would have to be destroyed when the window is destroyed so
> the next window with the same id doesn't inherit the style.

YES!!
I just wanted to suggest that myself (really!). My Email server was down
yesterday :-(

This enhancement would allow you to bind a key to a function that removes the
decorations from a single window (like "e" does).

For example you press C-M-F10 to make a window fullscreen -> maximize, remove
title, set Handlewidth 0.
Then press M-F9 and put everything back on and iconify...

I want that badly.

BTW: Why did you send this to fvwm-bug? I hope it's OK if I reply on
fvwm-workers...

-- 
joerg klemenz
[email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 16 Feb 2000 01:26:54 +0200

> Then press M-F9 and put everything back on and iconify...

Easily.

# ------------------------------------------------------------------------
Key F11 W SC FuncFvwmMaximizeFullScreen
Key F12 W SC FuncFvwmRestoreFromFullScreen

DestroyFunc FuncFvwmMaximizeFullScreen
AddToFunc   FuncFvwmMaximizeFullScreen
+ I Style $n NoTitle, NoHandles, BorderWidth 0
+ I WindowId "$w" RecaptureWindow
+ I WindowId "$w" Maximize true

DestroyFunc FuncFvwmRestoreFromFullScreen
AddToFunc   FuncFvwmRestoreFromFullScreen
+ I WindowId "$w" Maximize false
+ I Style $n Title, Handles, BorderWidth 5
# ------------------------------------------------------------------------

Press Ctrl-Shift-F11, Ctrl-Shift-F12.
Ok, I agree, it would be more clean with: Style (Id $w) Maximize.

Problems with the functions above:
  * Don't press Ctrl-Shift-F11 twice, you will not be able to restore.
    This is because Maximize after Recapture works differently...
  * Dominik, did you say Recapture is not needed after Style? :-)
    This will not work without it here.
  * If you have other style bindings and you execute them in between
    of Ctrl-Shift-F11/Ctrl-Shift-F12 - small memory leak, see other thread.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 16 Feb 2000 09:48:16 +0100

> decorations from a single window (like "e" does).

That's the idea :-)
 
> BTW: Why did you send this to fvwm-bug?

Because enhancement requests are archived in the bug tracking
system too.

> I hope it's OK if I reply on fvwm-workers...

Yes.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]