Subject: CVS hippo: Fixed compile problems for FvwmPager on Solaris

From: CVS <[email-masked]>
Date: Wed, 23 Feb 2000 09:14:17 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	hippo	00/02/23 09:14:17

Modified files:
	modules/FvwmPager: FvwmPager.c x_pager.c 

Log message:
Fixed compile problems for FvwmPager on Solaris

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Danek Duvall <[email-masked]>
Date: Wed, 23 Feb 2000 09:28:27 -0800

> Fixed compile problems for FvwmPager on Solaris

Thanks, Tim.

The next compilation problem that allowed me to see was:

    "FvwmPager.c", line 776: a cast does not yield an lvalue

Removing the (long) cast on the left side made it compile.  The only thing
left in FvwmPager was a warning in x_pager.c about a negative initializer
for an unsigned type on line 2636.

Is anyone interested in a full compile log with Sun cc, or is that likely
to be too painful to bear (and unnecessary now that things work)?  :)

Thanks much,
Danek