Subject: Core dump, menus with leading tabs

From: Tim Phipps <[email-masked]>
Date: Thu, 3 Feb 2000 15:35:50 GMT

Configuration Information [Automatically generated, do not change]:
uname output: SunOS tazmo 5.6 Generic_105181-15 sun4u sparc SUNW,Ultra-4
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /home/tim
sysconfdir: /home/tim/etc
libexecdir: /home/tim/libexec

FVWM Version: 2.3.14
FVWM_CONFIGDIR: unset
FVWM_MODULEDIR: /home/tim/libexec/fvwm/2.3.14
FVWM_USERHOME: /home/tim/.X

Description:

MenuStyle * MWM, Greyed Grey, Animation, TitleUnderlines1
MenuStyle * PopupOffset 0 100, AutomaticHotkeys, MenuColorset 0, ActiveColorset 1
DestroyMenu ResizeMenu
AddToMenu ResizeMenu
+ "Which way Jim?" Title
+ %xtrek_fed_e.xbm%"	7" my_resize_dir   0   0
+ %xtrek_fed_0.xbm%"	8" my_resize_dir  50   0
+ %xtrek_fed_2.xbm%"	9" my_resize_dir 100   0
+ %xtrek_fed_4.xbm%"	6" my_resize_dir 100  50
+ %xtrek_fed_6.xbm%"	3" my_resize_dir 100 100
+ %xtrek_fed_8.xbm%"	2" my_resize_dir  50 100
+ %xtrek_fed_a.xbm%"	1" my_resize_dir   0 100
+ %xtrek_fed_c.xbm%"	4" my_resize_dir   0  50

That's a tab after the first quote

(gdb) where
#0  0xef610954 in XTextWidth () from /usr/lib/libX11.so.4
#1  0x18978 in draw_underline (mr=0x8fa00, gc=0x73d28, x=0, y=36,
    txt=0x0, coffset=0) at menus.c:3292
#2  0x1828c in paint_item (mr=0x8fa00, mi=0x906d8, fw=0x9f068,
    do_redraw_menu_border=474168) at menus.c:3091
#3  0x178e0 in select_menu_item (mr=0x8fa00, mi=0x906d8, select=1,
    fw=0x9f068) at menus.c:2737
#4  0x15854 in MenuInteraction (pmp=0xefffeae8, pmret=0xefffead8,
    pdkp=0xefffe9e8, pdo_warp_to_title=0x6cf64) at menus.c:1704
#5  0x14218 in do_menu (pmp=0xefffeae8, pmret=0xefffead8)
    at menus.c:775
#6  0x1bb64 in menu_func (eventp=0x6f1bc, w=4194657, tmp_win=0x9f068,
    context=1, action=0x0, Module=0xefffecc4, fStaysUp=0)
    at menus.c:5020
#7  0x1bbc0 in popup_func (eventp=0x6f1bc, w=4194657, tmp_win=0x9f068,
    context=1, action=0xa5136 " ResizeMenu context c c",
    Module=0xefffecc4) at menus.c:5030
#8  0x3e748 in ExecuteFunction (
    Action=0xa5130 "Popup  ResizeMenu context c c", tmp_win=0x9f068,
    eventp=0x6f1bc, context=1, Module=-1, expand_cmd=676150)
    at functions.c:833
#9  0x2d06c in HandleKeyPress () at events.c:504
#10 0x2c8c8 in DispatchEvent (preserve_Tmp_win=0) at events.c:210
#11 0x2c944 in HandleEvents () at events.c:246
#12 0x33ed0 in main (argc=446464, argv=0x6f400) at fvwm.c:708

Repeat-By:
Try to pop the menu up
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 3 Feb 2000 18:42:40 +0100

> + %xtrek_fed_c.xbm%"	4" my_resize_dir   0  50

Fixed.  Too me some time to notice that X cut-and-paste doesn't
copy tabs :)  This was caused by the code that calculated the
column for the hotkey.  It happily assigned hotkeys to a label
consisting only of a bitmap.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]