Subject: Notification: incoming/570

From: [email-masked]
Date: Fri, 18 Feb 2000 18:36:24 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/570

Message summary for PR#570
	From: [email-masked]
	Subject: Direction
	Date: Fri, 18 Feb 2000 18:36:22 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Tim Phipps <[email-masked]>
Date: Wed, 23 Feb 2000 10:41:33 +0000

> Full_Name: Neil Zanella
> Version: 2.3.13
> 
> Performing focus with the direction command occasionally gives focus
> to a window from which it is impossible to give focus to another
> window via the Direction key bindings.

What are your Direction key bindings? And can you describe the
geometries of the windows that cause the problem?

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Neil Zanella <[email-masked]>
Date: Wed, 23 Feb 2000 16:51:10 -0330 (NST)

My key bindings are:

AddToFunc Raise-and-Focus "I" Raise
+                         "I" Focus

Key Up    A S  Direction North Raise-and-Focus
Key Down  A S  Direction South Raise-and-Focus
Key Right A S  Direction East  Raise-and-Focus
Key Left  A S  Direction West  Raise-and-Focus
Key Up    A SC Direction North Focus
Key Down  A SC Direction South Focus
Key Right A SC Direction East  Focus
Key Left  A SC Direction West  Focus

Here is the scenario. Since the NeverFocus window is in between the
two the focus can never pass between xterm1 and xterm2. Because of
the way the direction algorithm works this is possible in some cases
even when the NeverFocus window is not in between the two (it just needs
to be closer to xterm1 that to xterm2 I believe).

+--------+
| xterm1 |
|        |
+--------+

+-------------+
| NeverFocus  |
|   window    |
+-------------+

+--------+
| xterm2 |
|        |
+--------+

Regards,

Neil

---

From: Tim Phipps <[email-masked]>
Date: Thu, 24 Feb 2000 15:18:12 +0000

> to be closer to xterm1 that to xterm2 I believe).
Does it help to add the CirculateSkip style to the windows that have the
NeverFocus style? I think the problem you are having is due the the
Directions function (and the Next and Prev functions) being quite happy
to select a NeverFocus window. It then calls the function (Focus) which
does nothing with a NeverFocus window.

Cheers,
Tim.