Subject: Re: ActivePlacement (?)

From: Dominik Vogt <[email-masked]>
Date: Thu, 3 Feb 2000 19:40:55 +0100

On Wed, Jan 26, 2000 at 04:26:13PM -0600, [email-masked] wrote:
> Full_Name: Neil Zanella
> Version: 2.3.13
> CVS_Date: 
> OS: Linux 2.2.13
> X_Server: XFree86 3.3.2
> Submission from: (NULL) (129.128.153.50)
> 
> 
> Hello,
> 
> I just upgraded from Fvwm 2.3.12 to Fvwm 2.3.13.
> Everything seems to work fine except for one thing:
> When I make an xterm pop up it is always placed in
> the upper left hand corner as if SmartPlacement was
> not working.

I think that's fixed with the latest fix I made to the
placement code.  Can you verify this with the latest
snapshot, please?

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Neil Zanella <[email-masked]>
Date: Thu, 3 Feb 2000 15:58:59 -0330 (NST)

> placement code.  Can you verify this with the latest

Sure, but I don't see a snapshot with version greater than
2.3.13. Is this an unofficial snapshot you want me to
test. I will test it if you tell what to download and how
to apply the patches or whatever need to be done.

Thanks!

Neil

---

From: Dan Espen <[email-masked]>
Date: Thu, 03 Feb 2000 14:40:19 -0500

> to apply the patches or whatever need to be done.
There are no version numbers on snapshots:

ftp://ftp.fvwm.org/pub/fvwm/devel/snapshots/fvwm-snap-20000203.tar.gz

(Today)

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 3 Feb 2000 20:57:18 +0100

> to apply the patches or whatever need to be done.

Snapshots are built once a day from the development sources.
You can find a link to the latest snapshot on our downloads
page.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
The adjuration to be "normal" seems shockingly repellent to me; I see neither
hope nor comfort in sinking to that low level.  I think it is ignorance that
makes people think of abnormality only with horror and allows them to remain
undismayed at the proximity of "normal" to average and mediocre.  For surely
anyone who achieves anything is, essentially, abnormal.
                -- Dr. Karl Menninger, "The Human Mind", 1930

---

From: Neil Zanella <[email-masked]>
Date: Thu, 3 Feb 2000 17:48:30 -0330 (NST)

Hi,

I downloaded the snapshot and installed it.
The placement algorithm for new windows that pop up certainly looks
different than in 2.3.12. It no longer places windows in a "ladder like"
fashion. Instead it tries to cover as much empty space as possible. I can't
really say whether this is better or not. On one hand I like it. On the other
hand I don't always like windows to cover up my buttonbox when they pop up.
I think that perhaps one should have the option to choose between different
placement algorithms in the .fvwm2rc configuration file.

Thanks a lot,

Best Regards,

Neil

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 4 Feb 2000 11:29:20 +0100

> placement algorithms in the .fvwm2rc configuration file.

:-) Sometimes you should really have a look at the man page.  There
are more placement options then you want to have.  Try

  Style * SmartPlacement, CleverPlacement, RandomPlacement

Bye

Dominik ^_^