Subject: BUG: Iconify-maximize page flip

From: Joerg Klemenz <[email-masked]>
Date: Sun, 6 Feb 2000 20:04:17 +0100

> > stable 2.2.x releases.  With the current 2.3.13 beta all bugs
> > with windows flipping pages are hopefully fixed.

Yeah. Right.

I still run 2.3.13 (with sticky icons, anyone who does *not* use sticky
icons??).

Here is how to recreate the new bug:
Pop up window
maximize
iconify
go to other page
de-iconify
de-maximize
guess what

Comment:
I use the virtual desktop *a lot*. I don't have any icon managers or anything.
Just the good old icons on my desktop.
I experience quite a few page flips when applying styles or resetting the wm. I
realize that some of the apps are broken (get GQview if you look for a *really*
broken app). But the errors also occour with rxvt from Mr. Nation himself.
I will investigate this.

--
joerg klemenz
[email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 Feb 2000 07:56:23 +0100

> I still run 2.3.13 (with sticky icons, anyone who does *not* use sticky

I already considered removing the sticky icons style because I
have never seen a config using it :-)

> Here is how to recreate the new bug:

What should I guess?  I did mention that I already fixed this,
didn't I? ;-)

> broken app). But the errors also occour with rxvt from Mr. Nation himself.

No need to investigate, just download the latest CVS code and
send me detailed descriptions of your findings.  I recently 
rewrote most of the placement code and still can fix bugs
there quite efficiently.  BTW, before you report it, I just
learned that setting the StickyIcon style at run time doesn't
work well.  I'll vommit a fix in a few minutes.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Joerg Klemenz <[email-masked]>
Date: Tue, 8 Feb 2000 17:53:34 +0100

Am Mon, 07 Feb 2000 schrieb Dominik Vogt
> have never seen a config using it :-)

??
Is there a hidden irony I dont get? *Everyone* uses sticky icons. I know that.
Trust me.
  
> What should I guess?  I did mention that I already fixed this,

You said that you fixed the WindowShade bug. It was not obvious that also fixed
the other bug (even through they are related). I now have the CVS version from
yesterday installed and I had no page flips.
It also fixed the problem where GQview would appear on page 1 1 after a wm
reset. (xv still does, is the a workaround *possible*?)

I realize that GQview is broken in many ways.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 8 Feb 2000 19:45:19 +0100

> reset. (xv still does, is the a workaround *possible*?)

xv tries to be clever, but it's really being stupid.  When
it is reparented to the root window it moves itself to +0+0
(and covers whatever is already there, of course).  Perhaps
you can hack up something with PipeRead and WindowId, e.g.

  AddToFunc MyRestart
  + i next (xv*) exec store_xv_pos.sh
  + i none (xv*) exec echo > ~/.xv_pos
  + i Restart

store_xv_pos.sh would be a shell script looking like
this:

  xwininfo -tree -root |
    grep "xv 3\.10" |
    sed -e "s/^ *//g" -e "s/ .* //g" -e "s/+/ /g" |
    read WINID X Y
  echo "WindowId $WINID Move ${X}p ${Y}p" > ~/.xv_pos

And then add this to your RestartFunction:

  AddToFunc RestartFunction
  + i PipeRead ~/.xv_pos

(you may have to use the absolute path instead of ~).
Also, you may have to sleep a second or so before
doing this.  Another problem is that the window
is shifted by the size of the decorations, but you
get the idea.

Bye

Dominik ^_^