Subject: Style NoIcon --> Icon via a function

From: Olivier Chapuis <[email-masked]>
Date: Wed, 12 Jan 2000 12:13:33 +0100

Hello,
I've got some times a core dump by using  Style * Icon in a
function:

[olivier@snoopy olivier]$ gdb fvwm2 core
GNU gdb 4.17
This GDB was configured as "i386-redhat-linux"...
Core was generated by `fvwm2'.
Program terminated with signal 11, Erreur de segmentation..
find_solib: Can't read pathname for load map: Erreur d'entrée/sortie.
#0  0x4007a9bb in ?? () from /usr/X11R6/lib/libX11.so.6
(gdb) where
#0  0x4007a9bb in ?? () from /usr/X11R6/lib/libX11.so.6
#1  0x8069f13 in CreateIconWindow (tmp_win=0x80da470, def_x=0, def_y=0)
    at icons.c:121
#2  0x806b97e in Iconify (tmp_win=0x80da470, def_x=0, def_y=0) at icons.c:1208
#3  0x807b8d9 in apply_window_updates (t=0x80da470, flags=0xbffff730,
    pstyle=0xbffff734, focus_w=0x80d39c8) at update.c:237
#4  0x807bab8 in flush_window_updates () at update.c:325
#5  0x8058df0 in HandleEvents () at events.c:241
#6  0x805c7c0 in main (argc=1, argv=0xbffffbc4) at fvwm.c:706

Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 13 Jan 2000 11:27:28 +0100

> I've got some times a core dump by using  Style * Icon in a

...

Hi Olivier,

can you please post more detailed descriptions of what you're doing
to get these three core dumps?  (config snippets, step by step
instructions, ...).

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 13 Jan 2000 23:22:20 +0100

> to get these three core dumps?  (config snippets, step by step

Sorry for the delays but at present time my connection is
"irregular".

For the first core dump try this:

start fvwm2 with Style * NoIcon in .fvwm2rc (and no xterm)
Style "xterm" Icon xterm.xpm (or something in your ImagePath)
Open an xterm and iconify it
Then: Style * Icon
CORE DUMP in my machine ...

I will try to give instruction for the others core dumps but I cannot
reproduce them easily. Do you try my memory "menus experience", it seems
that the "menu" core dump arise only if before I unload/load a lot of menus,
modules config, styles ...etc a lot of  times (unload ~ destroy{Menu, Func,
ModuleConfig}, load ~ read some menus, modules config ...).

Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 13 Jan 2000 20:55:10 +0100

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 16 Jan 2000 00:05:36 +0100

> #6  0x805c7c0 in main (argc=1, argv=0xbffffbc4) at fvwm.c:706

Fixed.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 15 Jan 2000 23:24:40 +0100

> CORE DUMP in my machine ...

The exact circumstances are a bit different for me, but I think
I've fixed it.  I simply forgot to give the icon a font when the
style was changed from 'NoIcon' to 'Icon'.

Bye

Dominik ^_^