Subject: Re: fvwm fails to capture windows during startup

From: Dominik Vogt <[email-masked]>
Date: Sun, 16 Jan 2000 01:34:30 +0100

On Mon, Nov 29, 1999 at 07:55:10PM -0500, Dan Espen wrote:
> I just wanted to comment about that XSynchronize  and something else I
> noticed.  At work   I didn't notice   anything unusual, but  at home I
> thought I was having some kind of problem with my cable modem.
> 
> Normally menus just  flash on to  the screen.  With XSynchronize, they
> drew themselves one line at a time, about 2 seconds  per line.  What I
> found odd is that I can plainly see a whole  bunch of data transferred
> back and forth after the menu is completely displayed.
> 
> Oh,  I just checked again,  whats going on is, as  long as the pointer
> stays on the title, there's  constant network traffic back and  forth.
> It can be a title anywhere in the menu.

That's because of the 'popup delay'.  The loop times out again and
again, regardless of the position of the pointer or if the sub menu
is already open.  I've committed a patch.  Can you check again, Dan?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sat, 15 Jan 2000 20:22:49 -0500

> is already open.  I've committed a patch.  Can you check again, Dan?

The traffic I saw seemed to be restricted to titles.

Your patch seems to have "fixed" it.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 16 Jan 2000 02:32:54 +0100

> Your patch seems to have "fixed" it.

I can understand that I fixed it, but I don't understand
why it didn't happen over normal menu entries :-/

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 16 Jan 2000 02:35:04 +0100

> Your patch seems to have "fixed" it.

Oh, BTW, you reported some heavy network traffic on startup.
Can you find out what if this is abnormal?

Bye

Dominik ^_^