Subject: Notification: incoming/553

From: [email-masked]
Date: Mon, 24 Jan 2000 10:48:33 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/553

Message summary for PR#553
	From: [email-masked]
	Subject: fvwm-2.3.13 and Tru64
	Date: Mon, 24 Jan 2000 10:48:31 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: "Paul D. Smith" <[email-masked]>
Date: 24 Jan 2000 13:24:18 -0500

Hi Jeremie;

We appreciate the compiler warnings you're reporting and, indeed, I (at
least) consider some of them to be real bugs.  The sequence point
problem and the #undef with parens in particular must be fixed (the
first is an obscure bug waiting to happen, and the second may generate
a syntax error for some compilers).

In the future, I think it would be simpler if you just sent all such
messages directly to the [email-masked] mailing list rather than
trying to use the bug database.

Thanks again!

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Tue, 25 Jan 2000 14:53:56 +0000

> Thank you for the quick answer and the fixes. I downloaded 2.3.13 this
> morning.
> 
> when building libfvwm.a comes from the fact that wild.o is included twice
> in the archive. Is that necessary? (macro libfvwm_a_OBJECTS in

Fixed.

> The warning:
> cc: Warning: stepgfx.c, line 86: In this statement, the expression
> "rv=((rv>6553
> 5.0)||(rv<0.0))?rv-=sr:rv" modifies the variable "rv" more than once
> without an
> intervening sequence point.  This behavior is undefined. (undefvarmod)
>    rv = ((rv > 65535.0) || (rv < 0.0)) ? rv -= sr : rv;
> If I'm right, then lines 86, 87 and 88 can safely become:
> 
>     if ((rv > 65535.0) || (rv < 0.0)) rv -= sr;
>     if ((gv > 65535.0) || (gv < 0.0)) gv -= sg;
>     if ((bv > 65535.0) || (bv < 0.0)) bv -= sb;
> 

You are right. Fixed.

> It seems that FvwmIdent's dpy is not the same as declared in fvwm.h, which
> is defined in fvwm.c. I'd (humbly) suggest to rename FvwmIdent's dpy
> variable.

I've split fvwm.h into two files so that FvwmIdent.h doen't pick up a
bunch of extern declarations.

> #undef SIGN(x)
> -----------^

Fixed.  fvwm/fvwm.c has a 
#define fred(x) ...
#undef fred 

so I gues it's OK.

Cheers,
Tim.