Subject: obsoleting GlobalOpts before 2.4

From: Dominik Vogt <[email-masked]>
Date: Sat, 29 Jan 2000 14:41:33 +0100

I'd like to replace all remaining GlobalOpts options
before 2.4.  At the moment, the remaining ones are:

  SmartPlacementIsReallySmart / SmartPlacementIsNormal,
  ClickToFocusDoesntPassClick / ClickToFocusPassesClick,
  ClickToFocusDoesntRaise / ClickToFocusRaises,
  MouseFocusClickDoesntRaise / MouseFocusClickRaises,
  NoStipledTitles / StipledTitles,
  WindowShadeScrolls / WindowShadeShrinks.

These can all be implemented as styles easily.  The
WindowShade... styles would be abit inconsistent with
the WindowShadeAnimate command, but (a) that is already
the case and (b) I'd replace the WindowShadeAnimate
command with a style too (I'd like to have smooth
animations on small windows, but not on screen filling
ones).

My reasons are:

 1) We have already started to obsolete GlobalOpts
    by removing half of its options.  It's better to
    make a clean cut, not prolong the pain over
    several releases.
 2) GlobalOpts still needs a Recapture or Refresh to
    take effect (e.g. StipledTitles), so I'd have to
    rework it anyway.
 3) All the remaining options are undocumented at the
    moment.

As always:

  Two votes for the patch and none against it and I'll do it.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 29 Jan 2000 18:26:57 +0200

On 29 Jan 2000 14:41:33 +0100, Dominik Vogt wrote:
> These can all be implemented as styles easily.

If you feel this way and think it is easy, you should not ask anyone to
do (finish) your work. Beware of cut'n'paste errors, please. :)

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 31 Jan 2000 00:17:41 +0100

> do (finish) your work. Beware of cut'n'paste errors, please. :)

If we have some rules for a feature freeze everybody must
adhere to them.

Bye

Dominik ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 31 Jan 2000 03:27:14 +0200

> If we have some rules for a feature freeze everybody must

Since you fix most of the bugs, you have more rights.
But I have no problems to play by these rules.

I find your reasons about global options correct and you have my vote
to convert them to style options. I will test them (we test almost all of
the fvwm functionality in fvwm-themes anyway), but not the patch.

I am very bothered by the amount of bugs (I will post soon the bug set #3
about a session support and already started #4), so please return to bugs
as soon as possible. :/

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 31 Jan 2000 03:59:08 +0100

> But I have no problems to play by these rules.

I'm not talking about bug fixes but new features.  If we
want 2.4 anytime soon it's important that everybody follows
the rules.  I'm frustrated about the many, many unreproducable
problems - I had planned to do something else for about
three months now.  If I don't care about the rules I can't
expect anybody else to do so and then the number of bugs
will grow and grow, not diminish.

Granted, I do 90% of the work right now, but I wouldn't
get half as much done if I hadn't the support and the
competent advice of the many people on this list (not to
forget my cats that sweeten the long hours of hacking ^_^).
I like the idea of a 'team effort' to maintain fvwm.
If everybody thinks that I am the 'boss' of fvwm and
my enthusiasm dominates the others I think it's time for
a change.  I still have a lesson to learn: thanks to
the things that happened 15 months ago (when maintaining
fvwm passed on to the workers list and I volunteered for
the 2.2 release), fvwm will live on; bugs will be fixed
and new features implemented.  Time for me to take a
leave for a few months and have a real life again.  Of
course this won't happen before 2.4 is released.  At
the moment about 75 bugs stand betwween me and that
vague prospect.

> I am very bothered by the amount of bugs

Me too.

> (I will post soon the bug set #3
> about a session support and already started #4)

If you do so, *please*: I need better bug reports then the last
ones.  Can you imagine how much time I spend simply to try out
17 bug reports with vague descriptions?  As you have noticed,
we have lots of open bugs right now (I have 37 written on a
piece of paper on my desk, not counting ones from the last
month and those in Jitterbug) and my time is limited too.

> , so please return to bugs as soon as possible. :/

Sigh, I do what I can, but I can't work miracles.

Bye

Dominik ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 31 Jan 2000 06:52:16 -0500

>   Two votes for the patch and none against it and I'll do it.

you reasons are sound, and if we get rid of GlobalOptions its one less
place to look for problems.  So count my vote.

Brad
 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]