Subject: Re: Notification: incoming/540

From: Tomas Ogren <[email-masked]>
Date: Sat, 1 Jan 2000 16:35:25 +0100

On 31 December, 1999 - Dan Espen sent me these 2.1K bytes:

> > /usr/openwin/include/X11/Xlib.h:2063: ANSI C++ forbids declaration
> > `XSetTransientForHint' with no type
> 
> Note that all the error messages you sent us point to errors in
> Sun's header files.  Not that I think there's something wrong with
> Sun's header files.  More likely theres something wrong with your
> gcc installation.
> 
> I just  rechecked and I'm not  having any problem building with "gcc".
> (Solaris  2.6, gcc  2.8.1.  I don't  know  why, but "configure" picked
> "g++", not "c++" in my case.

g++ 2.95.x is a bunch more picky than 2.8.1. It doesn't like Sun's X
includes, not sure if defining "NeedFunctionPrototypes" breaks
anything...

g++ -fpermissive  to make it continue...

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 2 Jan 2000 06:48:54 +0100

> includes, not sure if defining "NeedFunctionPrototypes" breaks

On my Linux machine the build fails too if NeedFunctionPrototypes
is undefined.  I think the main problem is that this isn't
defined.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]