Subject: Notification: incoming/549

From: [email-masked]
Date: Thu, 13 Jan 2000 08:18:03 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/549

Message summary for PR#549
	From: [email-masked]
	Subject: Misleading error message from configure
	Date: Thu, 13 Jan 2000 08:18:01 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 14 Jan 2000 07:52:14 +0200

> I have just installed fvwm2 on an IBM RS/6000 running AIX.  I had some
> problems due to a rather misleading error message from configure:
> 
> [zeise] 85:fvwm-2.2.4>./configure --with-xpm-library=/usr/local/lib/X11 \
>         --with-xpm-includes=/usr/local/include \
>         --with-readline-library=/usr/unic/lib \
>         --with-readline-includes=/usr/unic/include
>    [ ... Most output deleted ... ]
> checking for strncasecmp... yes
> checking for strerror... yes
> checking for usleep... yes
> checking for atexit... yes
> configure: error: argument must be boolean
> [zeise] 86:fvwm-2.2.4>
> 
> .... I assumed that it was a problem with atexit, but after some time I
> discovered that it means that I had specified an incorrect directory
> in the --with-xpm-library option.  When looking at the configure script
> it looks like the error message really means "the argument is neither "yes"
> nor "no" nor a directory or file name.

This is the autoconf problem (bug?) - not specifying an option name and
not listing other then boolean possibilities in the error message.

Can you please report this to autoconf team?

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]