Subject: FvwmCommand pipes removed

From: Tim Phipps <[email-masked]>
Date: Thu, 27 Jan 2000 14:35:22 GMT

Configuration Information [Automatically generated, do not change]:
uname output: SunOS tazmo 5.6 Generic_105181-15 sun4u sparc SUNW,Ultra-4
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /home/tim
sysconfdir: /home/tim/etc
libexecdir: /home/tim/libexec

FVWM Version: 2.3.14
FVWM_CONFIGDIR: unset
FVWM_MODULEDIR: /home/tim/libexec/fvwm/2.3.14
FVWM_USERHOME: /home/tim/.X

Description:
	Not sure what's causing this but twice today the FvwmCommand pipes
	have been unlink()'d.  I also get a "fcs: read '#@killme^J'" in
	the log file if that means anything.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 27 Jan 2000 16:03:59 +0100

> 	the log file if that means anything.

This means that an old version of FvwmCommand is trying to talk
with a FvwmCommandS cimpiled after my patches.  Please check
if the problem goes away with a proper FvwmCommand version.
I'll remove the debug printf soon.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Mon, 31 Jan 2000 14:52:44 +0000

> I'll remove the debug printf soon.

The message in the log file has gone away but the pipes are still being
unlinked. I've figured out what is happening. Somehow in a restart the
old FvwmCommandS is not going away before the new one starts. When this
happens the new FvwmCommandS removes the pipes of the old one and
creates its own. The old one then gets to the close_fifos() and removes
the pipes (by name i.e. the pipes of the new FvwmCommandS). With the
following:

AddToFunc test I Killmodule FvwmCommandS
AddToFunc test I FvwmCommandS

and some debug I get this in the log file:

unlinking in open_fifos()
unlinking in close_fifos()

The first line is from the new FvwmCommandS and the second from the
old.  The problem goes away if I delay the start of FvwmCommandS.  I
think the fix is to not remove the pipes on exit since they get cleaned
up by the next FvwmCommandS that starts.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 31 Jan 2000 17:54:50 +0100

On Mon, Jan 31, 2000 at 02:52:44PM +0000, [email-masked] wrote:
> the pipes (by name i.e. the pipes of the new FvwmCommandS).

Ah, the old problem.  I don't know why, but FvwmCommandS is always
very slow to exit.  I wonder if this can be fixed.  This has been
bothering me for half a year.

Bye

Dominik ^_^