Subject: documentation bug

From: [email-masked]
Date: Wed, 12 Jan 2000 09:18:59 -0600 (CST)

Full_Name: Neil Zanella
Version: 2.3.12
CVS_Date: 
OS: 
X_Server: 
Submission from: (NULL) (129.128.153.50)

Hello,

The BoundaryWidth/NoBoundaryWidth should probably be documented in the
fvwm2 man page.

Best Regards,

Neil Zanella
[email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Neil Zanella <[email-masked]>
Date: Wed, 12 Jan 2000 16:52:04 -0330 (NST)

>From the fvwm2 man page:

      Style windowname options
              This  command  is  intended to replace the old fvwm
              1.xx global commands NoBorder,  NoTitle,  StartsOn-
              Desk,  Sticky,  StaysOnTop,  Icon,  WindowListSkip,
              CirculateSkip,    SuppressIcons,     BoundaryWidth,
              NoBoundaryWidth,   StdForeColor,  and  StdBackColor
              with a single flexible and comprehensive  window(s)
              specific  command.   This  command  is  used to set
              attributes of a window to  values  other  than  the
              default  or  to  set  the  window  manager  default
              styles.

BoundaryWidth / NoBoundaryWidth is there! ... I think what it does is it 
affects whether or not the one pixel "move" border gets drawn around
windows or not.

Thanks,

Neil

On Wed, 12 Jan 2000, Dominik Vogt wrote:

> On Wed, Jan 12, 2000 at 09:18:59AM -0600, [email-masked] wrote:
> > Full_Name: Neil Zanella
> > Version: 2.3.12
> > CVS_Date: 
> > OS: 
> > X_Server: 
> What do you mean?  There are no commands, styles, ... named
> BoundaryWidth and NoBoundaryWidth.
> 
> Bye
> 
> Dominik ^_^
> 
> -- 
> Dominik Vogt, Agilent Technologies, Dept. BVS
> Herrenberger Str.130, 71034 Boeblingen, Germany
> phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
>

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 13 Jan 2000 00:14:17 +0200

> affects whether or not the one pixel "move" border gets drawn around

Just like the man page says there were global commands [No]BoundaryWidth
in fvwm-1.xx, but they were replaced. The equivalent of BoundaryWidth is
style options BorderWidth and HandleWidth; and there is no need in
NoBoundaryWidth (for windows without title and borders), since border
widths and/or decors can be specified for individual window groups now.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 12 Jan 2000 18:04:21 +0100

Bye

Dominik ^_^