Subject: FvwmTheme core dumps on Transparent option

From: Tim Phipps <[email-masked]>
Date: Fri, 14 Jan 2000 14:02:08 GMT

Configuration Information [Automatically generated, do not change]:
uname output: SunOS tazmo 5.6 Generic_105181-15 sun4u sparc SUNW,Ultra-4
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /home/tim
sysconfdir: /home/tim/etc
libexecdir: /home/tim/libexec

FVWM Version: 2.3.13
FVWM_CONFIGDIR: unset
FVWM_MODULEDIR: /home/tim/libexec/fvwm/2.3.13
FVWM_USERHOME: /home/tim/.X

Description:
	I'm probably doing something dumb here but the line:
*FvwmThemeColorset 8 Transparent
	causes FvwmTheme to core dump with this error:

FvwmTheme: Cause of next X Error.
   Error: 9 (BadDrawable)
   Major opcode of failed request:  73 (GetImage)
   Minor opcode of failed request:  0
   Resource id of failed request:  0x1
 Leaving a core dump now

Stack trace:

#0  0xef488244 in _libc_kill () from /usr/lib/libc.so.1
#1  0xef43a608 in abort () from /usr/lib/libc.so.1
#2  0x18a28 in PrintXErrorAndCoredump (dpy=0x2d0e8, error=0xefffecf0,
    MyName=0x2cae8 "FvwmTheme") at XError.c:48
#3  0x132a8 in error_handler (d=0x2d0e8, e=0xefffecf0) at FvwmTheme.c:966
#4  0xef61f498 in _XError () from /usr/lib/libX11.so.4
#5  0xef611844 in _XReply () from /usr/lib/libX11.so.4
#6  0xef621478 in XGetImage () from /usr/lib/libX11.so.4
#7  0x12794 in parse_colorset (line=0x2c63d "") at FvwmTheme.c:646
#8  0x119a4 in parse_config_line (line=0x2b064 "") at FvwmTheme.c:188
#9  0x13280 in parse_config () at FvwmTheme.c:960
#10 0x11894 in main (argc=6, argv=0xeffff204) at FvwmTheme.c:120

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 14 Jan 2000 15:18:55 +0100

> #10 0x11894 in main (argc=6, argv=0xeffff204) at FvwmTheme.c:120

Um, of course we can't calculate the 'average' background colour
when using transparent backgrounds.  I'll commit a fix.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]