Subject: Gnome grun and focus problem

From: [email-masked]
Date: Tue, 25 Jan 2000 21:53:46 -0600 (CST)

Full_Name: Lee Skinol
Version: CVS
CVS_Date: Jan 25
OS: Linux 2.2.14
X_Server: XFree from RedHat 6.1
Submission from: (NULL) (168.143.0.8)

Here's a minimal .fvwm2rc:

---

# Invoke some xterms with the function keys.

Key F5 A N Exec xterm -sb -sl 1000 -geometry 80x35 -fg white -bg
darkslategrey
Key F6 A N Exec xterm -sb -sl 1000 -geometry 80x35 -fg white -bg
orangered4

# Alt-R invokes the Gnome runner.

Key r A M Exec grun

# The default window style.

Style "*" \
        ForeColor white, \
        BackColor lightsteelblue4, \
        HilightFore white, \
        HilightBack firebrick, \
        DecorateTransient, \
        RaiseTransient, \
        LowerTransient, \
        StackTransientParent, \
        DontFlipTransient, \
        Icon default.xpm, \
        HandleWidth 4, \
        MWMButtons, \
        SkipMapping, \
        SmartPlacement, \
        RandomPlacement, \
        GrabFocus, \
        GrabFocusTransient

GlobalOpts SmartPlacementIsReallySmart

---

When I invoke most any application, it comes up and gets the
focus.  However, with Gnome's grun, it starts up but *doesn't*
get the focus.  Is this a bug, or do I need a different style
flag?

Thanks.

Lee

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 31 Jan 2000 12:44:26 +0100

> Here's a minimal .fvwm2rc:

grun creates a transient of the root window.  The code didn't apply
either GrabFocus... style to such windows.  I'll commit a fix.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]