Subject: FvwmForm write file problem

From: Alex Wallis <[email-masked]>
Date: Tue, 4 Jan 2000 18:25:26 +1030

Okay, I've determined the problem with my FvwmBacker 
form is NOT my fault. Allow me to explain.

I use the folowing lines in the form which writes the config that
FvwmBacker reads.

*FormFvwmBacker.Command !/bin/echo "# This file created by FormFvwmBacker on :`/bin/date`. \n\
$(Com1?*FvwmBackerCommand (Desk $(Dsk), Page $(Px1) $(Py1) ) $(Com1)) \n\
$(Com2?*FvwmBackerCommand (Desk $(Dsk), Page $(Px2) $(Py2) ) $(Com2)) \n\
$(Com3?*FvwmBackerCommand (Desk $(Dsk), Page $(Px3) $(Py3) ) $(Com3)) \n\
$(Com4?*FvwmBackerCommand (Desk $(Dsk), Page $(Px4) $(Py4) ) $(Com4)) \n\
$(Com5?*FvwmBackerCommand (Desk $(Dsk), Page $(Px5) $(Py5) ) $(Com5)) \n\
$(Com6?*FvwmBackerCommand (Desk $(Dsk), Page $(Px6) $(Py6) ) $(Com6)) "  > $FVWM_USERHOME/themes/$BackTheme/ConfigFvwmBacker${BackTheme}.$(Dsk)

This produces errors for lines without a command of just writing ")" on the line.
Also the lines _with_ commands DO NOT have an ")" after $(Py1)
That is, it simply writes something like
*FvwmBackerCommand (Desk 0, Page 0 0  Exec xpmroot /home/awol/Fvwm2/icons/bckgnd3.xpm

At a guess the form doesn't recognize the last ")" as the close of $(Com1?
but it wrongly assumes the close is after the Page y variable.
Not having an ")" after the $(Com1) where it should be removes the error
of just writing a solitary ")" but doesn't affect anything otherwise.
I've tried a multitude of various combinations of using quotes, backslashes etc,
but all to no avail. It really is quite frustrating.
Can anyone help me out here?
How do I get the form to write that second parentheses in the correct place?

Let me know if you want more details.

Alex

P.S. You can check out my themes at 
http://www.dove.net.au/~awol/fvwm2/awols-fvwm-themes.tar.gz

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 04 Jan 2000 09:04:24 -0500

> $(Com1?*FvwmBackerCommand (Desk $(Dsk), Page $(Px1) $(Py1) ) $(Com1)) \n\
                                                                      ^

What I download was missing the indicated character.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]