Subject: FvwmTheme Core Dump

From: Olivier Chapuis <[email-masked]>
Date: Mon, 17 Jan 2000 10:46:21 +0100

Hello,
I tried the new option Transparent. After that FvwmTheme core dump
at any fvwm start/restart or if I try to start it. 
Then, It seems that fvwm remember the old colorset (when I tryed 
Transparent ...).
Olivier

FvwmTheme: Cause of next X Error.
   Error: 10 (BadAccess)
   Major opcode of failed request:  88 (FreeColors)
   Minor opcode of failed request:  0
   Resource id of failed request:  0x0
 Leaving a core dump now

[olivier@snoopy olivier]$ gdb /usr/local/libexec/fvwm/2.3.13/FvwmTheme core
GNU gdb 4.17
This GDB was configured as "i386-redhat-linux"...
Core was generated by `/usr/local/libexec/fvwm/2.3.13/FvwmTheme 30 4 none 0 8'.
Program terminated with signal 6, Abandon.
find_solib: Can't read pathname for load map: Erreur d'entrée/sortie.
#0  0x40121811 in ?? () from /lib/libc.so.6
(gdb) where
#0  0x40121811 in ?? () from /lib/libc.so.6
#1  0x4012284f in ?? () from /lib/libc.so.6
#2  0x804f963 in PrintXErrorAndCoredump (dpy=0x80532d8, error=0xbffff788,
    MyName=0x80532c8 "FvwmTheme") at XError.c:48
#3  0x804afd0 in error_handler (d=0x80532d8, e=0xbffff788) at FvwmTheme.c:967
#4  0x4007e159 in ?? () from /usr/X11R6/lib/libX11.so.6
#5  0x4007c926 in ?? () from /usr/X11R6/lib/libX11.so.6
#6  0x40072e96 in ?? () from /usr/X11R6/lib/libX11.so.6
#7  0x804c7e8 in GetShadowColor (background=65535) at ColorUtils.c:302
#8  0x804c94d in GetShadow (background=65535) at ColorUtils.c:360
#9  0x804ad60 in parse_colorset (line=0x8052e34 "") at FvwmTheme.c:876
#10 0x8049968 in parse_config_line (
    line=0x8052e0c "*FvwmThemeColorset 1 fg black, bg white\n")
    at FvwmTheme.c:187
#11 0x804afaf in parse_config () at FvwmTheme.c:961
#12 0x8049891 in main (argc=6, argv=0xbffffab4) at FvwmTheme.c:119
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 17 Jan 2000 11:02:55 +0100

> Then, It seems that fvwm remember the old colorset (when I tryed  

Do you have the new colour caching logic in libs/ColorUtils.c
or is this a problem with old code?

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 17 Jan 2000 19:40:49 +0100

> or is this a problem with old code?

I think that the mail of Brad answer this question.
Olivier