Subject: fvwm2 CVS segfaults at startup on LinuxPPC

From: [email-masked]
Date: Sat, 22 Jan 2000 21:09:37 -0500

Configuration Information [Automatically generated, do not change]:
uname output: Linux eris.aceldama.com 2.2.14 #1 Tue Jan 11 21:07:37 EST 2000 ppc unknown
Compiler: gcc
Compilation CFLAGS: -O3 -mcpu=604
prefix: /usr/local
sysconfdir: /usr/local/etc
libexecdir: /usr/local/libexec

FVWM Version: 2.3.13
FVWM_CONFIGDIR: unset
FVWM_MODULEDIR: unset
FVWM_USERHOME: unset

Description:
    For the past couple of weeks, fvwm 2.3.13 from CVS has segfaulted
    at startup. Compiled with -g, gdb reported segfault in the first
    call to XDrawSegments in libs/Graphics.c (line 48 right now).

Repeat-By:
    Compile and run fvwm2 on above system.
    Same problem when compiled with less optimization (-O2 -mcpu=604).

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 23 Jan 2000 15:57:53 +0100

>     Same problem when compiled with less optimization (-O2 -mcpu=604).

Should be fixed with the next snapshot.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]