Subject: fvwm-menu-desktop $mytimelimit variable

From: Alex Wallis <[email-masked]>
Date: Sat, 29 Jan 2000 02:52:41 +1030

I have a fairly lenghty set of kde menus, and
more than likely other people do too.
The defaults settings do not allow the perl script
to gather all the menu items, cutting out over half
of them. I've found that by setting the "my $timelimit"(line 153)
variable to a higher value (say 25) I'm able to get 
nearly all my menus.
Since I'm more of a butcher than a 'hacker', I wondered
if there was any reason for having this limit so brief.
My old cyrix 586 chip might take forever to process these
directories, but I'm a patient man and willing to wait.
Is it possible to include an option to adjust this value
when the script is invoked?
Something along the lines of...

  AddToMenu kde-user
            + DynamicPopupAction PipeRead 'fvwm-menu-desktop --desktop
kde-user --time-limit 25

It seems the script is installed on every build, so I have
to manually fiddle with it every time.

Alex
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 28 Jan 2000 18:47:49 +0200

>             + DynamicPopupAction PipeRead 'fvwm-menu-desktop --desktop

It is already possible, just command --i-know-what-i-do. :-)
I will rename this option to --time-limit later (I think Olivier agrees).

> to manually fiddle with it every time.

You can copy it to ~/bin and have ~/bin first in your $PATH.

Regards,
Mikhael.