Subject: BorderWidth > 6

From: [email-masked]
Date: Fri, 21 Jan 2000 05:54:54 -0600 (CST)

Full_Name: Shawn A.
Version: 2.3.13 fvwm-snap-20000120
CVS_Date: 
OS: PPC linux 2.2.14
X_Server: XF68_FBDev
Submission from: (NULL) (158.252.231.174)

Setting a non-flat border to bigger than 8 causes Fvwm to die.
To reproduce it:
make a .fvwmrc with only this in it:
Style * BorderWidth 4, HandleWidth 4

start fvwm2 then bring up FvwmConsole with the 
built in menu, give this command:
Style * BorderWidth 8, HandleWidth 8

<fvwm crashes here>

by giving "BorderStyle -- Flat" first, fvwm wont crash.
I think this first appeared sometime after fvwm-snap-20000113

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 21 Jan 2000 19:07:57 +0100

> I think this first appeared sometime after fvwm-snap-20000113

This doesn't crash for me.  Can you please fetch a stack trace
from the core file?

  # gdb fvwm2 core       (you may have to tell gdb the path to the sources)
  (gdb) where

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "shawn a." <[email-masked]>
Date: Fri, 21 Jan 2000 16:39:41 -0700

>   # gdb fvwm2 core       (you may have to tell gdb the path to the sources)
sa@space ~ % gdb fvwm2 core
GNU gdb 4.17.0.11 with Linux support
[...]
This GDB was configured as "ppc-unknown-linux"...
Core was generated by `fvwm2'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/X11R6/lib/libXpm.so.4...done.
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Reading symbols from /lib/libm.so.6...done.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /lib/ld.so.1...done.
#0  0xfe4bd28 in XDrawSegments ()
(gdb)

---

From: "shawn a." <[email-masked]>
Date: Fri, 21 Jan 2000 23:35:10 -0700

> >   # gdb fvwm2 core       (you may have to tell gdb the path to the sources)
Sorry, I forgot to type where... Here you go for reals this time:

sa@space ~ % gdb fvwm2 core
GNU gdb 4.17.0.11 with Linux support
[...]
This GDB was configured as "ppc-unknown-linux"...
Core was generated by `fvwm2'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/X11R6/lib/libXpm.so.4...done.
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Reading symbols from /lib/libm.so.6...done.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /lib/ld.so.1...done.
#0  0xfe4bd28 in XDrawSegments ()
(gdb) where
#0  0xfe4bd28 in XDrawSegments ()
#1  0x10046b08 in RelieveRectangle (dpy=0x10065570, d=8388799, x=3, y=3, w=508, 
    h=339, ReliefGC=0x1, ShadowGC=0x1, line_width=3) at Graphics.c:48
#2  0x10020c58 in draw_frame_relief (t=0x10092ba8, rgc=0x8000bf, sgc=0x1, 
    tgc=0x10094ae0, w_dout=3, w_hiout=254, w_trout=0, w_c=338, w_trin=1, w_shin=0, 
    w_din=1) at borders.c:284
#3  0x10020fe0 in RedrawBorder (cd=0x7ffff228, t=0x10092ba8, has_focus=268849988, 
    force=269044448, expose_win=3) at borders.c:497
#4  0x100224e8 in DrawDecorations (t=0x10092ba8, draw_parts=DRAW_ALL, has_focus=1, 
    force=2, expose_win=0) at borders.c:1252
#5  0x10042a20 in apply_window_updates (t=0x10092ba8, flags=0x7ffff638, 
    pstyle=0x7ffff5a8, focus_w=0x10092ba8) at update.c:213
#6  0x10042d40 in flush_window_updates () at update.c:325
#7  0x1001457c in HandleEvents () at events.c:241
#8  0x10018bac in main (argc=268763136, argv=0x0) at fvwm.c:707
#9  0xfce657c in Letext () at ../sysdeps/powerpc/elf/libc-start.c:106
(gdb) 

Thanks, if you need any more info just let me know.
sa

---

From: "shawn a." <[email-masked]>
Date: Sun, 23 Jan 2000 03:04:24 -0700

> #9  0xfce657c in Letext () at ../sysdeps/powerpc/elf/libc-start.c:106

Hi!
here is some more info, I hope it helps.

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs -I/usr/X11R6/include -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.3.13\" -DFVWM_CONFIGDIR=\"/usr/local/etc/fvwm\" -g -O2 -c borders.c
borders.c: In function `draw_frame_relief':
borders.c:282: warning: comparison is always true due to limited range of data type

-sa

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 23 Jan 2000 15:41:11 +0100

> borders.c:282: warning: comparison is always true due to limited range of data type

Uh, yes.  'char' is signed on some systems and unsigned on others.
Of course I can't compare a char with '-1' with some compilers.
I'll commit a fix in a few minutes. If you don't want to wait
for the next snapshot, just replace the '-1' on lines
282, 254 and 255 with '0xff' (borders.c).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 23 Jan 2000 15:48:51 +0100

> 282, 254 and 255 with '0xff' (borders.c).
                         ^^^^

0x7f that is.

Bye

Dominik ^_^

---

From: "shawn a." <[email-masked]>
Date: Tue, 25 Jan 2000 00:13:26 -0700

> > 282, 254 and 255 with '0xff' (borders.c).
Converting the -1 to 0x7f fixed it. thanks for the tip!

sa