Subject: CVS domivogt: * Added a colour cache to ColorUtils.c. Does it help, Dan?

From: CVS <[email-masked]>
Date: Sun, 16 Jan 2000 11:56:48 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	00/01/16 11:56:48

Modified files:
	.              : ChangeLog 
	fvwm           : add_window.c menus.c misc.c update.c 
	libs           : ColorUtils.c 

Log message:
* Added a colour cache to ColorUtils.c.  Does it help, Dan?
* Prevent some unnecessary menu animations.
* Removed debug code

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 17 Jan 2000 19:37:21 +0100

>         fvwm           : add_window.c menus.c misc.c update.c
                                                ^^^^^^
Hello,

You say nothings about your change in misc.c in the ChangeLog. 
Do you have modified UngrabEm for testing propose ? 
With the current UngrabEm, the Read, ModuleSynchronous and Recapture
options of BusyCursor are broken. Since UngrabEm is exactly as it was
before the BusyCursor patch ...

Also, can I add the style option (for the dynamic style change) to
BusyCursor or this is a to big feature for now ?

Olivier

---

From: Dan Espen <[email-masked]>
Date: Mon, 17 Jan 2000 19:55:44 -0500

> * Added a colour cache to ColorUtils.c.  Does it help, Dan?

Not visibly.

As I indicated earlier, the startup of fvwm tasks quite a bit of time
over a cable modem.  I've measured the bytes transferred:

Bytes in:  8,987,000 Frames: 11,000
Bytes out: 1,493,000 Frames:  8,000

This is to create 4 windows, "dclock", "biff", and 2 xemacs frames.

The dclock  and xbiff windows appear  undecorated very early on.  Then
nothing happens  for a very   long time.  (Except for data  transfer.)
Near the end, one or more xemacs frames appears, then fvwm decorations
start to appear on dclock, and biff, and both xemacs frames iconify.

I'm using  Exceed, and  I just  found the  trace disassembler   that I
neglected to  install the first  time  around.  I now have  a complete
trace of all the data  sent back and forth.  Its  33 million bytes, so
I'm going to have to do some work to find out whats  going on.  At the
end of this mail are the totals from the end of the disassembly.

I was surprised to see my XResources  sent 26 times  at 34K each time.
I see requests for "GetProperty" for property "RESOURCE_MANAGER", type
"STRING", window "root".

I'm not sure what that is, but I don't need all 34K of those resources,
so I can cut that down myself, although the 26 transfers seems too
high.

When I get a chance, I'll instrument the color cache so I can see
how many color allocations your change bypasses.  I'm guessing the XPM
library does most of my color allocation.

------------------------------------------
Packet Counts

    38 Atom Definition
     1 Comment
     1 Extension Definition
  4176 Server Time
    18 Socket Closed
    26 X Connection Attempt
  4458 X Reply (MSB)
  9776 X Request (MSB)

------------------------------------------
X Requests

  1058 AllocColor
     4 AllocNamedColor
   804 AllowEvents
    25 BigReqEnable (BIG-REQUESTS)
   713 ChangeGC
     8 ChangeHosts
     6 ChangeKeyboardControl
    90 ChangeProperty
     5 ChangeSaveSet
    81 ChangeWindowAttributes
   294 ClearArea
     3 CloseFont
   155 ConfigureWindow
     1 ConvertSelection
   161 CopyArea
     2 CopyPlane
     1 CreateCursor
   196 CreateGC
    30 CreateGlyphCursor
   134 CreatePixmap
    70 CreateWindow
     4 DeleteProperty
     7 DestroyWindow
   578 FillPoly
    10 FreeColors
   124 FreeGC
    13 FreePixmap
     2 GetAtomName
    51 GetGeometry
   906 GetInputFocus
     4 GetKeyboardMapping
     5 GetModifierMapping
   178 GetProperty
     3 GetSelectionOwner
    24 GetWindowAttributes
    28 GrabButton
  1596 GrabKey
     2 GrabPointer
    14 GrabServer
   123 ImageText8
     1 InstallColormap
   143 InternAtom
     4 ListExtensions
     6 ListFonts
     1 ListHosts
   247 LookupColor
    20 MapSubwindows
    27 MapWindow
    18 OpenFont
     1 PolyFillArc
   159 PolyFillRectangle
    73 PolySegment
    49 PolyText8
   134 PutImage
     3 QueryBestSize
    94 QueryColors
    52 QueryExtension
    15 QueryFont
  1047 QueryPointer
     3 QueryTree
     2 RecolorCursor
     5 ReparentWindow
    12 SendEvent
     1 SetAccessControl
    94 SetClipRectangles
     2 SetCloseDownMode
     5 SetInputFocus
     1 SetSelectionOwner
     1 ShapeCombine (SHAPE)
     4 ShapeMask (SHAPE)
     6 ShapeQueryExtents (SHAPE)
     5 ShapeSelectInput (SHAPE)
     2 TranslateCoordinates
     3 UngrabPointer
    13 UngrabServer
    10 UnmapWindow

---------------------------------

X Events

     1 ButtonPress
     1 ButtonRelease
     1 ClientMessage
    50 ConfigureNotify
     4 ConfigureRequest
    22 CreateNotify
     8 DestroyNotify
     4 EnterNotify
    22 Expose
     3 FocusIn
     3 FocusOut
    35 KeyPress
     2 LeaveNotify
    27 MapNotify
     3 MapRequest
    33 NoExposure
    18 PropertyNotify
     9 ReparentNotify
     1 SelectionNotify
    14 UnmapNotify
    13 VisibilityNotify

---------------------------------
X Errors

     9 Access
     4 Window

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 18 Jan 2000 12:09:24 +0100

> BusyCursor or this is a to big feature for now ?

That's some debug code I missed.  Can you restore the old code, please?
I can't remember exactly what I did.

Bye

Dominik ^_^

--
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]