Subject: Iconify stops iconifying after a desk switch

From: Tim Phipps <[email-masked]>
Date: Thu, 27 Jan 2000 11:14:10 GMT

Configuration Information [Automatically generated, do not change]:
uname output: SunOS tazmo 5.6 Generic_105181-15 sun4u sparc SUNW,Ultra-4
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /home/tim
sysconfdir: /home/tim/etc
libexecdir: /home/tim/libexec

FVWM Version: 2.3.14
FVWM_CONFIGDIR: unset
FVWM_MODULEDIR: /home/tim/libexec/fvwm/2.3.14
FVWM_USERHOME: /home/tim/.X

Description:
	I think this is caused by the fix to iconifying thrice.  When a
	window is created it can be iconified but if you switch to
	another desk and then back you can't iconify it again.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 27 Jan 2000 12:30:01 +0100

> 	another desk and then back you can't iconify it again.

Duh.  Then the 'is_map_pending' flag must be set after you
switched the desk.  This must be fixed.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 27 Jan 2000 18:06:46 +0100

> 	another desk and then back you can't iconify it again.

Fixed.

Bye

Dominik ^_^