Subject: BUSY_CURSOR hangs fvwm

From: Dominik Vogt <[email-masked]>
Date: Sun, 2 Jan 2000 11:12:38 +0100

With 2.3.12:

 1) Iconify any window
 2) Focus the icon
 3) While the icon is focused, trigger a 'Recapture'
    (e.g. from a root menu)

==> fvwm hangs in GrabEm() for 5 seconds

The place where it hangs is in builtins.c, do_recaptuere()

I have no idea why this happens. Olivier?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 3 Jan 2000 19:58:34 +0100

> I have no idea why this happens. Olivier?

Ah, forget it.  I know how to fix it: Call GrabEm *before*
the server is grabbed.

Bye

Dominik ^_^