Subject: Re: FvwmForm write file problem

From: Dan Espen <[email-masked]>
Date: Tue, 04 Jan 2000 20:17:43 -0500

Alex Wallis <[email-masked]> writes:
> On Wed, 05 Jan 2000, you wrote:
> > Alex Wallis <[email-masked]> writes:
> > > Okay, I've determined the problem with my FvwmBacker 
> > > form is NOT my fault. Allow me to explain.
> > > 
> > > I use the folowing lines in the form which writes the config that
> > > FvwmBacker reads.
> > > 
> > > *FormFvwmBacker.Command !/bin/echo "# This file created by FormFvwmBacker
>  on 
> > > :`/bin/date`. \n\
> > > $(Com1?*FvwmBackerCommand (Desk $(Dsk), Page $(Px1) $(Py1) ) $(Com1)) \n\
> >                                                                       ^
> > 
> > What I download was missing the indicated character.
> Yeah, like I explained that last bracket makes no difference.
> That was one of my many combinations.
> Try it with or without the correct syntax, the form still wont recognise it.
> i.e. it wont work with the above, or with...
> $(Com1?*FvwmBackerCommand (Desk $(Dsk), Page $(Px1) $(Py1) ) $(Com1) \n\
> or with....
> "$(Com1?*FvwmBackerCommand (Desk $(Dsk), Page $(Px1) $(Py1) ) $(Com1))" \n\
> or with...
> "$(Com1?*FvwmBackerCommand (Desk $(Dsk), Page $(Px1) $(Py1) ) $(Com1)" \n\
> etc... etc...

I've supplied a fix to FvwmForm, and right parens you need to pass
thru as part of a command, preceed with a backslash.

Speaking of parenthesis, shouldn't FvwmBacker be using square brackets to
indicate a conditional?
 
> Alex

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 5 Jan 2000 08:28:38 +0200

> Speaking of parenthesis, shouldn't FvwmBacker be using square brackets to

We use parenthesis for conditions in other commands like Current family,
WindowList, Style (in the future).

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Wed, 05 Jan 2000 06:23:13 -0500

> WindowList, Style (in the future).

Guess I was thinking of some earlier version of fvwm, you're right,
I found this is the man page:

          Note that earlier versions of fvwm required the  condi-
          tions to be enclosed in brackets instead of parentheses
          (this is still supported for backwards compatibility).

Oh well.